x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging error: graph is linked to private objects in an external package: RootComponent

I've been trying to package my project, which worked quite some time ago. However, now, whenever I try to package, it gives me an error because some file can not be cooked and saved.

The actual error message in the log is : UATHelper: Packaging (Windows (64-bit)): LogCook: Display: Cooking /Game/Levels/JFactory/JFactory -> C:/Users/xxx/Documents/Unreal Projects/xxx/Saved/Cooked/WindowsNoEditor/xxx/Content/Levels/JFactory/JFactory.umap UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: Windows GetLastError: Error: Windows GetLastError: The system cannot find the file specified. (2)

In the log file found in appdata, I found some more specific description as to why: "Can't save C:/Users/xxx/Documents/Unreal Projects/xxx/Saved/Cooked/WindowsNoEditor/xxx/Content/Levels/JFactory/JFactory.umap: Graph is linked to private object(s) in an external package. External Object(s): RootComponent

Try to find the chain of references to that object (may take some time)?"

I've tried deleting the files in question just to see what would happen, but then it would simply complain about other files instead. At first it was a simple actor component, after that one three levels in succession. Also, I do not know what kind of RootComponent this could refer to. A blueprint actor component is pretty standalone as far as I know, so I do not understand how it could reference some "external object".

I've been debugging this for hours now and I can not seem to find the cause. I guess the "graph" is the reference viewer? I have not found anything suspicious though.

Here the cook log with the specific problem: link text

Here the UAT log with the call stack link text

EDIT: I found some more relevant information: It seems to have some relation to a C++ scene component which has a USphereComponent named RootComponent. However, even after renaming it, deleting all visual studio generated data etc., the same error persists.

Product Version: UE 4.18
Tags:
uat-log.txt (285.7 kB)
more ▼

asked Mar 06 '18 at 05:57 PM in Packaging & Deployment

avatar image

Quexlaw
79 6 11 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question