x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why are my Render Targets not displaying correctly in packaged game

I have been testing something for my multiplayer game project in which I have the players view show up on monitors/screens in-game using the SceneCaptureComponent2d to Render Target method. All works fine in editor and when I package it to windows 64bit it works on my end but I have sent it to friends (3 friends have tested it) and they all get pixel-like artifacts (maybe the skybox too?) appearing when looking at the texture\in-game monitors (see screenshots below). It happens to them whether they're host or client but again, all is fine on my end. I'm stumped on this as I'm running the exact same build of my project. Are they missing some kind of third party driver? Any ideas to solve this is greatly appreciated, let me know if any more info is needed. alt text

alt text

Product Version: UE 4.18
Tags:
c2.png (506.9 kB)
c1.png (357.6 kB)
c1.png (357.6 kB)
c2.png (506.9 kB)
more ▼

asked Mar 07 '18 at 10:56 AM in Rendering

avatar image

k24uk
1 1

avatar image KaranMonster Oct 11 '18 at 08:50 AM

I am running into this issue too. I'd love to know if a solution was ever found.

avatar image k24uk Oct 11 '18 at 12:49 PM

Well the problem kinda half fixed itself when I updated to 4.20 (was on 4.18 when I posted this). Now when my friends play, only their own in-game 'monitor' displaying their POV is glitchy. If they look at somebody elses it works as it should. Now in my final game (when done), there will never be a opportunity for a player to see their own monitor (POV) only others, so the glitch shouldn't cause any trouble but would love to see it fully solved/fixed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question