x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot package Android Project

Hello,

First of all, I'd like to state that I've already read tons of similar posts and tried many different approaches to this problem. So unless I'm missing something obvious (in which case, I'm sorry :) ) please don't rush to mark my post duplicate!

So, I'm new in Unreal and I want to make an Android Game. I got the C++ Twin Stick Template, installed NVIDIA's code works, set up ndk/sdk/jdk/ant paths on project settings and I tried to launch my project.

Unfortunately I get this error http://lpaste.net/6382060319384010752

So far I've tried:

  • Switch from gradle to ant

  • Package instead of launch

  • Running UE4Editor.exe as Administrator

  • Enabled support for arm64

I have no idea how to approach this problem. I'm willing to uninstall everything from my computer (UE and Android related) and reinstall them, but I would like to avoid that if possible.

Please note that in code works I didn't install Nsight Tegra because it asked for Visual Studio 2015 but I need 2017 for Unreal... I don't think that's related though.

Update #1

After a long long night of recompiling, I decided to approach the problem differently. I created a new project, this time blueprints only. And this time UE packaged it without problems. I believe it's safe to assume that Visual Studio 2017 is the problem here... sigh . I guess I'll have to downgrade to VS 2015 and post another update.

Update #2

I installed VS 2015 and uninstalled 17. Still, same problem. I give up for now..

Product Version: UE 4.19
Tags:
more ▼

asked Mar 09 '18 at 12:24 AM in Packaging & Deployment

avatar image

DOS TheCrafter
16 1 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question