x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.18 VR Loading Screen Methods make HMD Black

I am trying to build a loading screen for my projects mostly for VR. I use Oculus Retail. My problem is whenever i try to use a method, my loading never ends. I mean headset stuck in black screen and loading finish doesn't fire.

I first tried this method https://wiki.unrealengine.com/Loading_Screen

Everything is fine until i add the code. Unreal compile fine but when i launch it black screen in HMD and stuttering view in my monitor. Even tough my headset doesn't display anything i can see it is tracking head movements in my monitor. But like 5 fps, its obviously trying to load something.

I have put a log after this line in the tutorial:

GetMoviePlayer()->SetupLoadingScreen(LoadingScreen);

after this line fire, this warning appears:

0]LogUObjectGlobals: Warning: Failed to find object 'Class None.'

black screen in HMD starts here.

After i ALT+F4 the preview window EndLoadingScreen(UWorld InLoadedWorld) fires.

So i changed the method to this one : https://docs.unrealengine.com/en-us/Platforms/VR/SplashScreens As interesting as it is, it made the same thing. Black Screen in HMD, 5 fps preview in monitor...

Maybe i don't know the simplest setting to tick, maybe it is a bug with my headset type. I would be appreciated of any help. Thank you...

Product Version: UE 4.18
Tags:
more ▼

asked Mar 12 '18 at 02:33 PM in VR

avatar image

sadbutrue
1 1 2 3

avatar image sadbutrue Mar 13 '18 at 10:56 AM

I just found this tutorial for Oculus and it is same https://docs.unrealengine.com/en-us/Platforms/Oculus/HowTo/SplashScreens

They all work on VR Preview but not when i launch the game. The first tutorial was "for dedicated server only" so i forgot about "play in editor" mode.

I have been digging about this a lot and found out there are some people having the black screen issue. In the early days like 4.10 someone said it was an Nvidia driver issue, like if you use Intel drivers it works. Intel graphics cant be used due to framerate so that's not an option. I will try and install 4.17 now. maybe its a version issue. There are no updates for splash screen in 4.18 release notes so i assume what works in 4.17 should work on 4.18 too right ?

avatar image sadbutrue Mar 13 '18 at 12:44 PM

Guess i've made progress...

https://docs.unrealengine.com/en-us/Platforms/Oculus/HowTo/SplashScreens

in this tutorial when i put "add loading screen" to the VrPawn->BeginPlay Oculus gets in to splash screen in "OculusVR Plugin" and stuck there. (I noticed this when i put a texture in to Project Settings->Plugins->OculusVR->Splash Screens->Splash Descs. It is an array of splash screen descriptors accepting textures and their locations in world.) But when i put a 0.2 delay before the "add loading screen" node there is no black screen. But of course no splash screen at start.

In "Play in editor" mode a grey world with loading text with an Unreal logo is coming up in HMD. So Unreal editor can make the transition from Oculus client to Unreal client.

Only solution for me is start game with an empty level, after delaying 0,2secs show the splash screen manually.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question