x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project fails to build on 4.18.3 - -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command

I have a project that's built using 4.16.3. I tried to build the project on 4.18.3 today, and got a bunch of errors, the reason of which I fail to understand. One such error is :

H:\GitHub\PaintGame 4.18\PaintGame.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.

I've never encountered anything of this sort before, and I have tried looking around but nothing seems to help. Any help or a nudge in the right direction is greatly appreciated.

Product Version: UE 4.18
Tags:
more ▼

asked Mar 13 '18 at 06:22 AM in Packaging & Deployment

avatar image

hussainAbis
6 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

Maybe you should see in the log file what was the problem during your packaging.

Anyway, here's some solutions i have that solved few packaging problem, check if one of them help you:

  • see if you don't have multiple instances of your project running

  • check the length of the path of some assets

  • check if all your blueprint compile correctly

  • if you are using c++, check if all your code compile correctly

I hope it will help you, without your log file it is not so easy. If you still can't package your project, please provide your log file

more ▼

answered Mar 13 '18 at 11:20 AM

avatar image

Rayster
11 1 3

avatar image hussainAbis Mar 13 '18 at 08:45 PM

Thanks for the reply Rayster. Unfortunately, I'm still stuck though. I had closed UE completely before starting the process on 4.18, and the BPs and C++ Code compiles just fine on 4.16.3, so I presume that shouldn't be an issue ? I followed your suggestion of checking the path length, but I'm still at the same place I started. Here's my log file

Thanks for your time and all the help.

paintgame.log (42.6 kB)
avatar image Rayster Mar 15 '18 at 02:02 PM

Hi, sorry for the late answer.

Did you try to replace all your

#include "Kismet/HeadMountedDisplayFunctionLibrary.h"

with

#include "HeadMountedDisplayFunctionLibrary.h"

?

Otherwise I do not really see what's going on with your issue

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In my case, the error was due to an erroneous Blueprint function return type declaration: UFUNCTION(BlueprintCallable, Category = Sound) static unsigned int playSound(...)

Instead of unsigned int, I had to use uint8 for instance to make UE happy. https://answers.unrealengine.com/questions/98206/missing-support-for-uint32-int64-uint64.html

Obviously, the error message did not help find this one. The actual error can be found in the VS output tab instead of the error list.

more ▼

answered Jun 06 '18 at 04:51 PM

avatar image

imperialex19
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question