x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Incorrect foliage color in the editor preview when using PerInstanceRandom in foliage material

When using PerInstanceRandom in the foliage material the foliage in the editor preview has incorrect "broken" color. In the game preview all works fine.

STR:

  1. Create new blank project.

  2. Create new material.

  3. In the material editor add vector3 node and change its colour (yellow for example).

  4. Add PerInstanceRandom node.

  5. Add "Add" node.

  6. Connect vector3 and PerInstanceRandom to Add node.

  7. Connect add node to Base Color or/and Emissive Color. alt text

  8. Apply changes and save material.

  9. Create new static mesh and set new material in material slots.

  10. Add new static mesh to foliage brush.

  11. Place foliage on level.

  12. Save and reopen level.

Result: Foliage color is broken. alt text

Expected Result: alt text

Additional Info: In the 4.18.x all works fine.

Product Version: UE 4.19
Tags:
image-10.png (385.4 kB)
image-8.png (1.3 MB)
image-9.png (824.6 kB)
more ▼

asked Mar 16 '18 at 10:50 AM in Bug Reports

avatar image

geekB0B0
66 1 2 7

avatar image Jeff A ♦♦ STAFF Mar 16 '18 at 08:09 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1410408-unreal-engine-bug-submission-form

Thanks

avatar image geekB0B0 Mar 20 '18 at 11:03 AM

Hi, thank you!

I submitted an issue report using the new Bug Submission Form, I will update this thread if some feedback comes back.

avatar image Draxus Mar 21 '18 at 06:28 PM

I'm also experiencing this issue in 4.19 and was able to reproduce it in a new blank project. Here is the bug report to vote on for anyone else having trouble. https://issues.unrealengine.com/issue/UE-56272

avatar image Accel Sjöström Apr 10 '18 at 03:39 PM

I have the same issue. Very annoying, but at least the correct colors are being displayed when actually running the game.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Fixed in 4.19.2

more ▼

answered May 02 '18 at 02:27 PM

avatar image

geekB0B0
66 1 2 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question