x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged Win64 game crashes on Level Start with CaptureBuildData Error

Packaging and running my game in 4.18 worked as expected.

I made a copy of the game for 4.19 and packaged it without making any changes.

The packaging succeeded and I was able to start up the game, but when trying to load the first level, the game crashed with the message:

 <ErrorMessage>Assertion failed: CaptureBuildData.FullHDRCapturedData.Num() &gt; 0 || CaptureBuildData.EncodedHDRCapturedData.Num() &gt; 0 [File:D:\Build\++UE4+Release-4.19+Compile\Sync\Engine\Source\Runtime\Engine\Private\MapBuildData.cpp] [Line: 406] 

It looks like this check is new in 4.19. Any ideas on what I can do to pass the check?

Product Version: UE 4.19
Tags:
more ▼

asked Mar 17 '18 at 05:06 PM in Packaging & Deployment

avatar image

The Compiler
31 7 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I was able to fix the problem by choosing "Build Reflection Captures" from the Build Options Dropdown Menu. Once I did that, the game no longer crashed when loading the first level.

more ▼

answered Mar 17 '18 at 05:57 PM

avatar image

The Compiler
31 7 7

avatar image gon. Jun 21 '18 at 11:41 PM

Cool, I had the same error window after packaging the game with 4.19.2 Now seems to work or at least can not replicate this error again.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question