x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Only first particle emitter spawning in Play or Simulation.

Hey all.

So I have a series of emitters in my particle system, each emitter with a different GPU sprite because for some reason it doesn't choose a single sprite randomly per particle in one emitter like it does in CPU. (I've been trying some suggested workarounds, but for now that's how I've got it)

In the normal viewport, I can see all the different sprite emitters working fine, but as soon as I simulate it through my blueprint or try to "play" I only get the first emitter spawning.

Possibly unrelated but something I noticed in the same particle system is that when I duplicate an emitter identically, but change the sprite, suddenly the Constant for Spawn doesn't work on the duplicated emitter! It only starts giving me particles when I bump the amount higher than the original emitter.

So frustrated here. Any insight would be great.

Product Version: UE 4.18
Tags:
more ▼

asked Mar 17 '18 at 07:04 PM in Using UE4

avatar image

makkuro_
8 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question