x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Question on racing game (beginner)

Hi, I'm a beginner in Unreal Engine 4. I'm just trying out the default racing track with the added racing track I had modelled from Maya LT. When I press play, the car does not fit the racing track that I had created, do you know how to fix the default car to the track I had modelled and imported to the Unreal Engine?

Thank you for the help,

Saeho Oh

alt text

Product Version: UE 4.18
Tags:
more ▼

asked Mar 18 '18 at 06:02 PM in Using UE4

avatar image

seho90
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

if you modeled it as seen in the picture as one piece then i would guess that the collision generated when you imported your track isnt correct. basically if you didnt define custom collision and had unreal create the collision for you then it probably just made a cube around your mesh. try opening the mesh then go to the toolbar at the top and click collision then select simple collision. the box (should be green) that comes up when you do this is the simple collision and is what affects if you can pass through things.now to fix your issue you can either go and create your own custom collision in the modeling software (which eventually you will want to learn to do) or you can use a workaround in engine that will work for the purposes of learning though i dont know how it would affect optimization in a finished game (hence why i recommend learning to make custom collision).

so to do the workaround im talking about you will just need to change a setting in the mesh. so with the mesh opened go to the details panel on the right and search for collision complexity. change the value of collision complexity to "use complex as simple". this will allow your car to exist in the inset area of your track.

hope this helps. if this wasnt the issue or you need more help let me know

more ▼

answered Mar 18 '18 at 07:34 PM

avatar image

ThompsonN13
10.1k 33 10 25

avatar image seho90 Mar 31 '18 at 11:16 PM

Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question