x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linux UE crash on init

Hey I am using Ubuntu 16.04, I am trying to build and run UE using this guide: https://wiki.unrealengine.com/Building_On_Linux
I have succeed to compile UE, then I have tried to run it, UE gave me the option to create new project so i did then it crashed.
After that every time i have tried to open UE it crashed over and over. I have tried to run it using gdb as the guide say to debug errors. This is the backtrace of the crash:

0 FLinuxPlatformMisc::DebugBreak () at /home/ssd/UnrealEngine/Engine/Source/Runtime/Core/Private/Linux/LinuxPlatformMisc.cpp:765
#1 0x00007ffff0bc798d in IsRHIDeviceIntel () at /home/ssd/UnrealEngine/Engine/Source/Runtime/RHI/Private/RHI.cpp:553
#2 0x00007fffde81f6ba in FDeferredShadingSceneRenderer::ShouldPrepareDistanceFieldScene (this=0x7ffed8dcc900) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Renderer/Private/DistanceFieldAmbientOcclusion.cpp:722
#3 0x00007fffde8117ee in FDeferredShadingSceneRenderer::Render (this=, RHICmdList=...) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.cpp:608
#4 0x00007fffdedf692a in RenderViewFamily_RenderThread (RHICmdList=..., SceneRenderer=) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Renderer/Private/SceneRendering.cpp:2077
#5 FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::EURCMacro_FDrawSceneCommand::DoTask(ENamedThreads::Type, TRefCountPtr const&) (this=, CurrentThread=ENamedThreads::StatsThread, MyCompletionGraphEvent=...) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Renderer/Private/SceneRendering.cpp:2275
#6 0x00007fffdee27505 in TGraphTask FSceneViewFamily*)::EURCMacro_FDrawSceneCommand>::ExecuteTask(TArray&, ENamedThreads::Type) (this= out>, NewTasks=..., CurrentThread=) at Runtime/Core/Public/Async/TaskGraphInterfaces.h:784
#7 0x00007ffff6ebda17 in FBaseGraphTask::Execute (this=0x7ffecc9f0e10, NewTasks=..., CurrentThread=ENamedThreads::StatsThread) at Runtime/Core/Public/Async/TaskGraphInterfaces.h:466
#8 FNamedTaskThread::ProcessTasksNamedThread (this=, QueueIndex=, bAllowStall=) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Core/Private/Async/TaskGraph.cpp:650
#9 0x00007ffff6ebcee3 in FNamedTaskThread::ProcessTasksUntilQuit (this=, QueueIndex=) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Core/Private/Async/TaskGraph.cpp:559
#10 0x00007ffff0e63331 in RenderingThreadMain (TaskGraphBoundSyncEvent= out>) at /home/ssd/UnrealEngine/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp:326
#11 0x00007ffff0e77ad2 in FRenderingThread::Run (this=0x7ffed9272300) at /home/ssd/UnrealEngine/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp:478
#12 0x00007ffff6ef9bcc in FRunnableThreadPThread::Run (this=0x7ffecd570000) at /home/ssd/UnrealEngine/Engine/Source/Runtime/Core/Private/HAL/PThreadRunnableThread.cpp:25
#13 0x00007ffff6ed56cf in FRunnableThreadPThread::_ThreadProc (pThis=0x7ffecd570000) at Runtime/Core/Private/HAL/PThreadRunnableThread.h:177
#14 0x00007ffff7bc16ba in start_thread (arg=0x7ffecd56b700) at pthread_create.c:333
#15 0x00007fffeb84341d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

As you can see it fails on function IsRHIDeviceIntel, BTW the GPU is navidia
How can i solve this?

Product Version: UE 4.18
Tags:
more ▼

asked Mar 19 '18 at 07:51 PM in Using UE4

avatar image

Darkstorm1997
82 9 17 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you running NVidia vendor drivers?

more ▼

answered Mar 19 '18 at 07:58 PM

avatar image

RCL STAFF
2.7k 59 6 88

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question