x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material instance parameters losing values in 4.19

  1. In 4.18 or older versions, create a material with a material function in it.

  2. Enter and put some textures inside the material function.

  3. Set textures to be "Shared: Wrap" but keep one texture at "From texture asset" and connect them to corresponding slots.

  4. Multiply a UV node by a scalar parameter per texture so you can individually control tiling of each texture separately through material instance.

  5. Create and apply the material instance to landscape or something else, then set custom tiling values to each parameter.

  6. Save the project.

  7. Open the project in 4.19.0

Result: Texture samplers that are set to be "Shared: Wrap" have lost the parameter values associated with them. But the ones that were set to be "From texture asset" still have their values.

What we mentioned in repro steps regarding tiling, does not limit to tiling, but any other calculations associated with samplers that are set to be "Shared: Wrap".

4.18:

alt text

4.19.0:

alt text

Product Version: UE 4.19
Tags:
more ▼

asked Mar 21 '18 at 05:13 PM in Rendering

avatar image

Maximum-Dev
714 13 17 22

avatar image Chosker Mar 21 '18 at 06:09 PM

also experiencing this!

avatar image Velo Mar 25 '18 at 05:00 AM

Having the same problem. Quite simply, material instances of a parent landscape material will not save their changed settings properly. If I change, for example, the near distance tiling of a texture in the landscape material instance, as soon as I close and re-open it, it reverts back to default settings -- instead of saving the changes that were made.

avatar image aurelienmartel Mar 29 '18 at 01:25 PM

I've got the exact same problem... Pretty annoying!

avatar image Maximum-Dev Mar 26 '18 at 09:46 PM

Hello,

Any word from Epic?

avatar image Jon X ♦♦ STAFF Mar 27 '18 at 08:55 PM

Unfortunately I wasn't able to reproduce this issue with the repro steps you've provided.

In 4.18, I created a new project, then created a material with a material function: MatFunction Mat I made sure all textures were set to "Shared: Wrap" except for the texture being used for the Normal, which was kept as "From texture asset."

Here you can see the Material Instance and the scalar parameter values I entered, along with the resulting scene. MatInstance 418Editor

Next, I saved the project and opened it in 4.19 and all the scalar parameter values were copied over correctly and the scene looks as expected. 419Editor

Please let me know if there is anything I've missed.

mf.jpg (264.3 kB)
m.jpg (174.2 kB)
mi.jpg (189.5 kB)
418-screenshot.jpg (420.9 kB)
419.jpg (896.5 kB)
avatar image Chosker Mar 27 '18 at 09:01 PM

I believe the 'lost' parameters only get lost when they reside inside a material function. your repro doesn't attempt to do that - I know the original repro steps didn't mention it but they do now, as well as the comments below

given the seriousness of the issue, if that still fails I'd suggest the following:

  • from the marketplace import any of the "Realistic Landscapes Bundle" packs into a new project

  • open any of the showcase maps

  • notice the material instance parameters are lost

  • repeat in 4.18, and see how everything works correctly

avatar image OverRated_AU Mar 27 '18 at 10:29 PM

Hi Jon, i think the real issues comes from mats with mat functions parameters inside other mat function, these parameters are not saved, so you need to create 2 mat functions add one inside the other then try saving the parameters inside that 2nd mat functuon inside a mat instance, you can do this just in 4.19.

avatar image Maximum-Dev Mar 27 '18 at 11:05 PM

Hi @Jon X ♦♦, Someone else from Epic said on the forum thread that they were able to reproduce the issue: https://forums.unrealengine.com/unreal-engine/marketplace/creators-hub/1447833-4-19-bug-and-marketplace-content?p=1451320#post1451320

avatar image rabellogp Apr 19 '18 at 03:22 PM

Well, just adding to the thread that I'm also experiencing this. 90% of my materials are instantiated from a couple of base materials heavily based on Material Functions with parameters inside them. I just can't upgrade any of my projects to 4.19 without massive rework right now...

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

4.19.2 fixed this issue! Thanks for the fast fix.

more ▼

answered May 01 '18 at 05:55 PM

avatar image

Blitzkrieg-bob
11 7 1

(comments are locked)
10|2000 characters needed characters left

I reported a similar bug on day one, where mat functions parameters inside other mat functions wouldn't be saved in mat instances.

more ▼

answered Mar 23 '18 at 08:26 AM

avatar image

OverRated_AU
162 6 14 27

avatar image Maximum-Dev Mar 24 '18 at 07:04 PM

Ah yeah I added the material function in the repro steps (steps 1/2).

(comments are locked)
10|2000 characters needed characters left

Hey all,

Trying to get a repro on this (Incorporated recent suggestion from OverRated_AU). Still not seeing it.

Attaching my 4.18 base project, anyone see what needs to be added/changed?

link text

mfbug.zip (1.5 MB)
more ▼

answered Mar 29 '18 at 07:56 PM

avatar image

Alex O ♦♦ STAFF
2.5k 3 8 9

avatar image OverRated_AU Mar 29 '18 at 09:41 PM

Hi Alex, This seems to have more than the single issue i have found, please download my debug project (materialinstancebug.zip) below, go into Test_Mat_Inst and set a value in TRYSAVEME save it and close it then reopen it, you will see the saved parameters is lost but then again it seems to be saving it to the above parameter? so it seems there's more than just lost save data going on here, now i thought it mite of been because there no feed back from these to main node, but then again in the 2nd debug project (materialinstancebugtest2.zip) it is but instead this time its not saved in the above parameter its just not saved at all.

I hope these debug projects help.

link text

link text

avatar image Alex O ♦♦ STAFF Mar 30 '18 at 03:13 PM

Thanks for these!

Just to clarify: were these created in 4.18 and converted to 4.19?

avatar image OverRated_AU Mar 30 '18 at 03:16 PM

These are just made in 4.19, but creating them in 4.18 and converting the project you end up with the same result ether way.

avatar image Maximum-Dev Mar 29 '18 at 10:47 PM

Hi @Alex O ♦♦, In addition to OverRated_AU's provided files, is there any way I can give you our project in private? unfortunately can't share our projects in public. But it's probably going to help you see what's going on between 4.18 and 4.19.

avatar image a.traverso.ovo Mar 30 '18 at 10:29 AM

Hi all, if it can be of any help I found out the problem lies in the expression guids of the material instances parents, there appears to be some collisions of IDs between materials expressions and materials functions expressions, leading to the rewrite of parameters names and consequent shuffle of parameters values.

Still not sure how or why this problem arises only when updating to 4.19, maybe a deserialization bug?

I got the materials to render correctly by invalidating the expression guids in the parameters, but the editing is still broken.

avatar image Alex O ♦♦ STAFF Mar 30 '18 at 04:06 PM

I have entered this bug as https://issues.unrealengine.com/issue/UE-57086 Critical Priority

avatar image OverRated_AU Mar 30 '18 at 05:33 PM

Great thanks for the heads up Alex O.

avatar image steter Apr 08 '18 at 02:15 AM

The target fix is 4.20? So 4.19 and all of the cool Paragon assets are essentially unusable because, quite frankly, landscapes suck without the ability to alter material function parameters. What a waste of time converting to 4.19, then. Can't this get bumped up? Extremely disappointing.

avatar image Maximum-Dev Apr 08 '18 at 02:31 AM

We discussed this in forums and sadly 4.20 is the closest they promised. Our game is currently broken due to this though, others as well. Along with tons of content on ue4 marketplace. It really is disappointing to have to wait ~3 months to see a fix.

avatar image OverRated_AU Apr 08 '18 at 03:15 AM

Yeah it pretty bad, what i have done is just continue to use 4.19 and when 4.20 comes out ill just copy over my terrain materials from 4.18 so all there data is restored.

avatar image Ashmon Apr 16 '18 at 02:37 PM

Maximum-Dev, Can I get a link to the forum post in which this is being discussed? Thanks!

avatar image Blitzkrieg-bob Apr 10 '18 at 08:51 AM

Same here, basically not able to use any of our Landscape Material Instances anymore - super critical in terms of meeting deadlines.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question