x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does my material keep breaking?

This issue is driving up the wall so much that I may stop using Unreal altogether. I have a UMaterialInstance pointer that I declare in a header file that I then assign as a default in a blueprint.

 UPROPERTY(EditAnywhere, BlueprintReadWrite)
 UMaterialInstance* ShieldMaterialInstance;
 UMaterialInstanceDynamic* ShieldMaterialInstanceDynamic;

I set up this dynamic material in PostInitProperties:

 void AOnyxPlayer::PostInitProperties()
 {
     Super::PostInitProperties();
     if (ShieldMaterialInstance == nullptr) return;
     ShieldMaterialInstanceDynamic = UMaterialInstanceDynamic::Create(ShieldMaterialInstance, nullptr);
     ShieldMaterialInstanceDynamic->SetScalarParameterValue(
         TEXT("Thickness"), ShieldThickness
     );
     ShieldMesh->SetMaterial(0, ShieldMaterialInstanceDynamic);
 }

I make a material, a new material instance with that material as a reference, and then I assign the material instance to this material instance pointer. It works initially in the editor and in the viewport. However, literally doing anything breaks it. Making a change in the C++ breaks it, going to standalone mode breaks it, saving the material breaks it. What is going on here?

Here's a GIF.

https://imgur.com/a/m1LTr

As you can see, in the editor it's got this weird broken material. I have to compile the blueprint repeatedly to get it work in the editor or the viewport. Any have any ideas?

Product Version: UE 4.18
Tags:
more ▼

asked Mar 23 '18 at 03:06 AM in C++ Programming

avatar image

toxicg0d
34 3 2 5

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I gave up and switched to blueprints. Endlessly frustrating.

more ▼

answered Mar 23 '18 at 12:17 PM

avatar image

toxicg0d
34 3 2 5

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question