x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

dark lines between static meshes on higher quality than preview

Hello,

I have a problem when I bake light on higher quality than preview I got these dark lines between meshes. On preview there aren't any lines but light quality is overall lower quality. I tried some solutions that I have in mind and none of them are working. Lightmaps are pretty big resolutions from 512 to 2048, I don't know what is the problem here, It might be static mesh problem, but it is weird that on preview quality I don't have these problems. Also I don't get any error message after baking light, so I guess everything is fine with overlapping and other similar stuff.

Thank you for any suggestions you have. Cheers.alt text

Product Version: UE 4.18
Tags:
capture.png (1.4 MB)
more ▼

asked Mar 23 '18 at 02:02 PM in Using UE4

avatar image

PeraCul
3 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Makigirl, thanks for replaying, appreciate that,

I tried on highest possible resolution (4096) and problem remains, maybe if I break every big mesh on much smaller peices will help? About ''face snapped'' thing, do you basically mean, that I should back at 3dsmax and every mesh adjust not to touch or intersect between each other just to be close each other and not to touch? Thanks again.

more ▼

answered Mar 23 '18 at 02:36 PM

avatar image

PeraCul
3 1 2 4

avatar image Makigirl Mar 23 '18 at 02:54 PM

Depends on your mesh... I would never go higher than 2048 (even 1024). I would break up your floor per room! And yes this can be fixed at the basics: in your 3d app... And no "making objects floating" won't help!!: whenever you want to get proper shadows at corners/edges you'll have to edge snap walls/floors to each other OR break up your mesh and keep the lightmap uv islands only for the visible, non overlapping parts!

avatar image PeraCul Mar 23 '18 at 03:18 PM

Ok, I will try breaking meshes think that will help. I think I understand now, just a plastic example to ask? If I have a wall for example, you mean I should break that wall,on two meshes one mesh should be plane part that is visible, and second mesh would be remaining parts that are not visible? Did I understand that correctly?

avatar image Makigirl Mar 23 '18 at 04:04 PM

IMO!! Never break up your meshes into planes: one sided objects (can) mess up your realistic lighting bounces!

Ok a quick "guide"! :D alt text

First row images: how you should or shouldn't place your meshes to avoid those corner artifacts. Second row: if your meshes DO overlap/intersect you can still have an option: cut up your mesh's structure/face (while keeping it a single mesh, just it's surface) so that you have the visible part/face(s) (4th pic in your case darker red) "selectable" and in your lightmap uv you keep just this area and place the covered parts(polygons) (no point to calculate that area anyway) outside of your uv space. Like this you'll get light calculated only where you need to no wasted uv space! I hope I'm not too confusing! :D

meshuv.jpg (88.3 kB)
avatar image PeraCul Mar 23 '18 at 04:18 PM

Thanks for the explanation, its not confusing, I understood. Will back to my 3d model than and first will break my big meshes, than will see what will happen, after that will make these changes you explained. Thanks for your effort to explain me these stuff. Will post results when I test everything.

avatar image PeraCul Mar 24 '18 at 03:10 PM

Hi Makigirl, just want to inform you, that I did everything you said and everything worked perfectly there is no any black lines, when I adjusted these stuff you said, thank you a lot for helping me with those issues.

avatar image Makigirl Mar 24 '18 at 04:02 PM

No worries I'm glad you get the result you want! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi!

If you're talking about the dark edges at your walls/floor.... I guess your walls and floor are "face snapped"... if you want to get rid of those completely you should have your meshes not to intersect nor face overlap... ...If you set a higher resolution lightmap to your floor those errors should get smaller/ migh disappear... the resolution is still low (I guess it's a big mesh so even if you set to 512 or 2048 it still doesn't have enough resolution!/

more ▼

answered Mar 23 '18 at 02:16 PM

avatar image

Makigirl
1.2k 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question