x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Mac UE4.18.3 can't build lighting

Hi, I'm teaching an intro class in UE4. We have UE4.18 installed on all the Macs and none of the machines can build lighting. The lighting just won't build and it just says Build failed without much of a reason.

Is there anything glaring about the Mac version that we may have overlooked?

we taught UE4.5 in the past and didn't have lighting issues then. We do get messages about xcode not being installed not sure if that is related though.

please help thanks!

Product Version: UE 4.18
Tags:
more ▼

asked Mar 23 '18 at 02:57 PM in Using UE4

avatar image

jonbellini
55 7 12 15

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

turned out to be a permissions problem.

Our IT person figured out that the Unreal Lightmass and Unreal Frontend needed a firewall permission.

more ▼

answered Mar 27 '18 at 07:58 PM

avatar image

jonbellini
55 7 12 15

avatar image mark.app Jun 13 '18 at 05:51 AM

I've been stuck on this for months where the Lighting wont build on the Mac for some weird reason. I tried your solution as you can see in the below screenshot but it didn't fix my issue.

Can you explain in more detail on how you fixed this issue?

I hope you can help me as I have noticed that a fair few unreal developers have experienced this issue and no one has really found a solid solution.

Many thanks in advance :-)

alt text

avatar image mark.app Aug 07 '18 at 08:40 AM

Can someone please give me an update on how to fix this issue as I'm still stuck with the lighting build error?

avatar image Spyro 999 Aug 25 '18 at 12:39 PM

For me it stucks only when I place a landscape on a level

(comments are locked)
10|2000 characters needed characters left

Hello If it still can help, I just ran into this issue on HS, and fixed it from the first suggestion If you're using Little Snitch, erase all the connections rules related to Unreal Editor, and create two allowing all connections to any server, in and out.

more ▼

answered Oct 30 '18 at 06:51 PM

avatar image

PascalN
1

avatar image xpgained Jan 28 '19 at 09:00 PM

As of 4.21 I am still seeing this issue. I haven't done anything crazy to break this system. Brand new imac. 24gb ram, i7, etc. fresh install of unreal. create new project with the third person template. Delete the stairs for example. The rebuild text appears in the window. Go to the top of the editor and rebuild lighting and it fails. Red text never goes away.

avatar image xpgained Jan 28 '19 at 09:16 PM

I added the exceptions to the mac firewall that mark.app posted above and reenabled my firewall. Changed some stuff in my level and built lighting only and it worked!!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question