x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Subsurface Profile Artefact (Line Along Mesh)

When I'am using a subsurface profile, I'am getting a wierd line along mesh. Bigger subsurface radius split this line in more. I got material from PhotorealisticCharacter in Marketplace and it is working great. Did I miss something? alt text

alt text

Product Version: UE 4.19
Tags:
more ▼

asked Mar 24 '18 at 01:17 PM in Rendering

avatar image

DotBow
11 1 5 8

avatar image Adeptus Jun 01 '18 at 10:27 AM

We are having the same issue. Please EPIC check this out. It wasnt there in 4.18 and its a pain to look at.

avatar image Constantine Xeni Jul 20 '18 at 02:46 PM

I've encountered this problem too. It seems though in PIE doesn't produce this glitch. Haven't tested packaging for development/shipping.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I looked into this and found out that this happens with deferred shading when r.SceneColorFormat is set to less than 4. Enabling forward shading or setting r.SceneColorFormat to 4 should get rid of the line.

I've filed an official bug report for this.

more ▼

answered Jun 01 '18 at 12:35 PM

avatar image

Chris-M
21 1 3

avatar image Ardures Jun 18 '18 at 09:13 PM

Thanks, it's gone :)

avatar image Constantine Xeni Jul 26 '18 at 09:44 AM

Yeah it's gone, as is the subsurface. Enabling forward shading isn't the solution.

avatar image Chris-M Jul 26 '18 at 10:03 AM

Try setting r.SceneColorFormat to 4 instead.

avatar image Constantine Xeni Jul 26 '18 at 03:58 PM

Yes r.SceneColorFormat 4 does the trick. In UE4 version 4.20 this glitch is gone, even if you use r.SceneColorFormat 0 there is no visual artifact.

avatar image Constantine Xeni Jul 23 '18 at 02:30 PM

This is the weirdest glitch i have seen by far. It only happens in my project. I've even imported my SK into unreal's Photorealistic Character project which shows as it should. I fiddled around with the project settings, new map etc. and the only way to make it disappear is by resizing the editor's viewport. Btw the resizing doesn't happen in unreal's project.

alt text

capture.png (29.5 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question