x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Compiling shader over billion O_O

When we moved from 4.18 to 4.19 our project, we got some strange problem: If we change parameter in material Engine start compile shaders, and that happen even if we change parameter on 1. Other problem we see - engine start compile shaders, and in viewport message show that need to compile 4000000000 shaders (max from int-type). I think its happen, becouse counter of compiling shaders get down over 0 =)

But problem is not of that counter. Problem is that Engine over and over again compile shader even if I move some node.

I tried delete Intermediate, Saved, Binaries. I tried delete Data cache.

But problem dont want to go out =(

[1]: /storage/temp/235076-снимок.png

Product Version: UE 4.19
Tags:
снимок.png (215.9 kB)
more ▼

asked Mar 26 '18 at 04:43 AM in Using UE4

avatar image

DenKuzn
59 5 8 10

avatar image Sreeragh Mar 26 '18 at 06:54 AM

try deleting the ProjectFolder/DerivedDataCache/Boot.ddc file and run project again. It should complile properly.

avatar image DenKuzn Mar 26 '18 at 08:13 AM

We created new project, and migrated content. In New project same problem.

avatar image Sreeragh Mar 26 '18 at 08:17 AM

Can be possibly a problem with a specific material you have. You can check by importing materials one by one if you have the time.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

For resolve that problem with compile shader always just turn off Live Preview.

Problem with 4kkk shaders - its not my area of responsibility =)

more ▼

answered Mar 26 '18 at 08:58 AM

avatar image

DenKuzn
59 5 8 10

avatar image Furkan_X Feb 28 '19 at 01:07 PM

Can someone explain where the Live Preview can be found :P

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question