x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Screen space reflection has always 0 roughness

Hi!

In the project, I'm currently working at, there are many reflective materials.

While working on metal material, I found very strange reflections depending on the angle of view:

It looks good at this angle, but Looks good

wrong from this angle Looks bad

At the right of the second image, you can see that it is not rough. The material is set to roughness = 0.1. Sphere reflections are placed.

I checked the Screen space reflection and it seems that it causes the problem. When I turn it off and use only information from sphere reflection captures, everything looks correct. But in many places I wish to have screen space reflections enabled. The problem is that they are always not rough.

Another screenshot with roughness set to 0.3

Good

alt text

So you can see that it is entirely reflective when rendering the part of metal using screen space

What could be the problem?

Product Version: UE 4.19
Tags:
bug1.jpg (73.4 kB)
bug2.jpg (92.5 kB)
bug3.jpg (101.9 kB)
bug4.jpg (48.5 kB)
more ▼

asked Mar 26 '18 at 04:14 PM in Rendering

avatar image

RealCoder
38 2 3 9

avatar image Fernando Rabello Feb 14 '19 at 08:00 PM

Same problem here, no matter the quality settings.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Blurred SSR requires better quality settings.

more ▼

answered Mar 30 '18 at 08:22 PM

avatar image

Deathrey
7.8k 130 31 293

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Found the solution. Set the default post process Screen Space Reflection quality to above 60 or create a post process volume and set the same property to above 60. Also, raise the Max Roughness to a higher value more close to 1. If value is 0.5 for example, any roughness value above 0.5 will now show any SSR. The quality setting above 60 give support for blurring SSR.

more ▼

answered Feb 14 '19 at 09:01 PM

avatar image

Fernando Rabello
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question