x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

FBX importing without textures

I've been given an .fbx of a model created in 3DS Max to put into my Unreal project, but something happens that it loses all of the textures in the process. All of the geometry imports just fine, and all of the materials are there, but the diffuse map part of the textures have all been replaced with varying shades of Easter egg pastels. Now, I can fix it provided I go and reconnect the materials to the texture files one at a time, but I really shouldn't have to do that given that .fbx is a standardized file format. I've tried a whole bunch of different things to try to get the textures to come along for the ride, from monkeying with all the different import settings to just putting the file in the same folder as the textures and importing from there, but nothing works. Any idea what I'm doing wrong and how to fix it?

Product Version: UE 4.19
Tags:
more ▼

asked Mar 27 '18 at 10:43 PM in Everything Else

avatar image

Texian
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

OK that is fine. so solutions you have some. Unreal uses OpenGL and DirectX for its graphics system. so the shaders from 3Ds max and the other DCC programs such as lambert, phong, and more are not directly compatible (I say this because of the datasmith stuff that came out) now you will notice that unreal uses deferred rending by default, so instead of defuse its albedo (or in the material editor base color) so options:

  1. with in your DCC program such as max or maya you should see shader options for a DirectX shader or the like (not sure about openGL, but im sure its there)

  2. then you do your shader work on that and then you can import it and unreal will understand

But my recommendation:

  1. don't import any materials for textures, for a good organization system that can be used for source control

  2. will work best if you import the textures to there own location

  3. and in another folder structure make the materials with in unreal

  4. IE in my solution that I also use for projects with others

  5. its Assets at the top

  6. then on for props (meshes)

  7. materials

  8. textures

  9. then under those folders each is sub dived further

  10. this is easy on source control, for it your suing GitHub or Bit bucket you don't want your textures on source (because their large and will cause you overflow issues, so use drop box for the textures)

Questions?

more ▼

answered Mar 28 '18 at 03:10 AM

avatar image

GIGA-Money
232 2 11 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question