x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Parameter not showing in instance

Hi! I've been building a material for several hours and everything worked fine. At some point any new parameters that I created stopped showing in instances. I've tried renaming, creating different types of parameters, but nothing shows up. When I edit previously created parameters in the parent, changes do appear in instances. I don't remember changing any settings. I'm attaching 2 images: parent material with new parameters "BColourEn" and "BColour", neither of which appear in the instance (second image). Any help would be appreciated! alt text

alt text

Product Version: UE 4.19
Tags:
0.png (216.7 kB)
1.png (159.2 kB)
more ▼

asked Mar 30 '18 at 09:17 AM in Using UE4

avatar image

r_lighter
11 2 2

avatar image klu00 May 02 '19 at 08:19 PM

Have you found a solution to this ? I'm facing the same issue...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Parameters which are not connected to the output node (in any downpath) are not shown in the material instance editor window. So, if you miss parameters, check the material if they are connected properly.

more ▼

answered Jun 02 '19 at 03:41 PM

avatar image

Algorithman
53 5 7 10

avatar image r_lighter Jun 02 '19 at 06:19 PM

Hey, thanks for the reply. All the nodes downstream were connected but it's a good guess, I feel it was a bug. sorted it out by copying all the nodes and pasting into a new material.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question