x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Error: Assertion failed: BatchElement.IndexBuffer->IsInitialized()

Hey everyone!

I've been trying to integrate the Voxel Plugin from the UE4 marketplace, but I've been running into issues. I've finally gotten my project to build, but whenever I attempt to load a map featuring the voxel plugin (I've tried debugging every other way to see if it's something else) my game crashes immediately.

I am replicating terrain and the client has the ability to create a listen server (the plugins docs clearly state that replication works for dedicated server mode only) so I think this could be an issue if I did something to accidentally spin up the listen server across all levels regardless of user settings.

I'm building again without terrain replicated enabled so I'm hoping that will fix it before this gets answered, but I wanted to drop the question just in case I can't figure this out.

If it's not replication, I think this issue has something to do with how the Voxel Plugin is multithreading. I've pushed the plugin past the recommended limits with a 32x32x1 component map with a voxel size of 500...I know that's INSANE and the docs state to make a 4x4x2 map for a larger map, but it's never clearly stated that there's a threshold for map size and other projects have worked with this map size without issue...

I've tried testing on a 16x16x1 map with a voxel size of 100 (significantly smaller than ANYTHING I have ever successfully used this plugin for) and still experienced crashes.

I would also like to note that I attempted to use BPThreads to handle some other multithreading tasks, but since abandoned the plugin after optimizing my code.

Here are my logs from running the editor in standalone and running the packaged .exe. I've been working with the engine since 4.6 so I've gotten pretty good at reading logs, but I think I'm just missing it since I've been working on this for so long. link text

Any help is greatly appreciated!

Thank you,

Entro

Product Version: UE 4.18
Tags:
uat-log.zip (225.2 kB)
more ▼

asked Mar 31 '18 at 02:15 AM in Packaging & Deployment

avatar image

Entropikz
113 18 21 26

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ugh sorry guys...I was still using the Voxel Invoker from the Marching Cubes plugin which was causing a crash because the invoker was returning a null world. Thank you to everyone who might have been looking into this with me, but my game is working now!

o7 Entro

more ▼

answered Apr 02 '18 at 05:15 AM

avatar image

Entropikz
113 18 21 26

avatar image Entropikz Apr 02 '18 at 05:17 AM

Also want to add that both plugins are pretty phenomenal. Thank you so much to both developers for taking the time to release the projects! Without them I don't think I would be able to provide my users with a quality map at the scale I'm trying to achieve.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question