x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

HTML5 Uncaught Error at Array

I'm getting an error when playing my game in a web browser. The funny thing is that it works just fine until I use the numpad as input option. WASD is binded to the same keys as the numpad and works fine. But when using the numpad, it throws this error at me:

Uncaught Error at Array. (blob:http://localhost:8000/e3dae6c9-ff2e-41dc-a524-132fd15ef4ca:1:38841) at emscripten_asm_const_v (blob:http://localhost:8000/e3dae6c9-ff2e-41dc-a524-132fd15ef4ca:1:43602) at ZN5EKeys6AddKeyERK11FKeyDetails (wasm-function[92097]:150) at ZNK16FInputKeyManager15GetKeyFromCodesEjj (wasm-function[92095]:262) at ZN17FSlateApplication7OnKeyUpEijb (wasm-function[92847]:54) at ZThn148_N17FSlateApplication7OnKeyUpEijb (wasm-function[92892]:13) at ZN20FHTML5InputInterface4TickEfRK9SDL_EventR10TSharedRefI14FGenericWindowL7ESPMode0EE (wasm-function[17210]:660) at ZN17FHTML5Application19PollGameDeviceStateEf (wasm-function[17198]:538) at ZN17FSlateApplication19PollGameDeviceStateEv (wasm-function[97741]:128) at _ZN11FEngineLoop4TickEv (wasm-function[688]:8305)

The project packed HTML5 size is 144 MB, but does not complain about this on packaging or running the game in a browser.

Do anyone know what could cause this to happen?

Product Version: UE 4.19
Tags:
more ▼

asked Apr 01 '18 at 02:54 PM in Everything Else

avatar image

AinSophAur
10 6 6 10

avatar image nick.shin STAFF Apr 02 '18 at 03:14 PM

ah - i had a bug about using the "windows" (i.e. "super") key. (note to self: UE-54056) i'll fix this to handle the num pad properly... sorry about that... i'll post the solution here when i get to this.

avatar image AinSophAur Apr 02 '18 at 03:44 PM

Thank you very much in advance. :)

avatar image Spider Mycron Jan 07 '19 at 02:01 PM

Hello, i run my game on browser normally but after few minutes it crash with below error message :

Uncaught Error at Array. (blob:http://www.momentsnews.com/455ead26-7bc4-466d-a80f-95d1b4478912:1:38841) at emscripten_asm_const_v (blob:http://www.momentsnews.com/455ead26-7bc4-466d-a80f-95d1b4478912:1:43523) at ZN22FOutputDeviceAnsiError9SerializeEPKwN13ELogVerbosity4TypeERK5FName (wasm-function[177976]:250) at ZN13FOutputDevice8LogfImplEPKwz (wasm-function[178718]:221) at ZN13FOutputDevice4LogfIA64_wJiiiiEEEvRKT_DpT0 (wasm-function[21349]:64) at __ZN6FDebug12AssertFailedEPKcS1_iPKwz (wasm-function[177433]:180) at __ZN25TSlateElementVertexBufferI12FSlateVertexE13PreFillBufferEib (wasm-function[94020]:132) at __ZN24FSlateRHIRenderingPolicy27UpdateVertexAndIndexBuffersER24FRHICommandListImmediateR15FSlateBatchDataR25TSlateElementVertexBufferI12FSlateVertexER24FSlateElementIndexBuffer (wasm-function[94019]:467) at __ZN24FSlateRHIRenderingPolicy27UpdateVertexAndIndexBuffersER24FRHICommandListImmediateR15FSlateBatchData (wasm-function[93748]:17) at __ZN17FSlateRHIRenderer23DrawWindow_RenderThreadER24FRHICommandListImmediateRNS_13FViewportInfoER23FSlateWindowElementListbb (wasm-function[94365]:3204)

how to fix that please ?

Thanks

avatar image nick.shin STAFF Jan 07 '19 at 05:30 PM

spider mycron, it seems one of your slate element might be missing from the project?

have you tried running your project from the editor? (i.e. PIE: "play in editor") usually, this will generate any errors in the Message Logs you can follow up on. (this can be found in: UE4's menu bar -> Window -> Developer Tools -> Message Log, and be sure to check all of the entries in there).

alt text

i would also recommend you try running your native platform (e.g. windows client) and see what error show up there as well.

hope this helps!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

i have a fix in for 4.20

but, basically, HTML5PlatformInput.cpp needed to be updated with:

  • Engine/Source/Runtime/InputCore/Private/Linux/LinuxPlatformInput.cpp

NOTE: the HTML5 version uses SDL_SCANCODE_xxx (while the linux version uses SDLK_xxx)

more ▼

answered Apr 03 '18 at 03:47 PM

avatar image

nick.shin STAFF
476 5 4 9

avatar image AinSophAur Apr 03 '18 at 04:37 PM

Thank you for adding this fix to 4.20. I'll be looking forward to that. I'm using the release version, so I guess it's not that easy to fix unless I use the git version. But thanks a lot. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

hello, Thanks so much for kidly response, i found some blueprint errors from logs the level work fine inside the editor . anyways any other level i may publish on web is not work on mobile browser , it load for a bit then crash

is there solution to have game or level work on mobile browser ?

Thanks

more ▼

answered Jan 07 '19 at 05:33 PM

avatar image

Spider Mycron
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question