x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Collision channel settings does not work when both interacting Actors are Pawns/Characters

Problem:

Collision channel settings are completely ignored when both interacting actors are extended from Chracter.

How to reproduce:

  • Create a BP extended from 'Character' named BP_DummyPawn.

  • Add a capsule component as root, with a skeletal mesh as its child.

  • In the collision channel settings for Capsule component, set 'Pawn' channel to 'Ignore' or 'Overlap', Enable collision and set Type to 'Pawn'

  • Create a second 'Pawn' extended from 'Character' called 'BP_PlayerPawn'

  • Add a capsule component as root, with a skeletal mesh as its child.

  • Leave every other settings at their defaults

  • Edit the Game mode class and set BP_PlayerPawn as the default

  • Place and instance of BP_DummyPawn on the map.

  • Start playing and see that the player pawn is blocked by BP_DummyPawn even if it is asked to ignore collisions with other Pawns

However if BP_DummyPawn is extended from 'Actor', everything works fine. It will ignore collisions with the player charcter.

So it looks like the presence of MovementComponent is what causes the issue.

Similar issue reported here: https://answers.unrealengine.com/questions/76027/capsulecomponent-collision-when-moving.html

Product Version: Not Selected
Tags:
more ▼

asked Aug 01 '14 at 03:31 AM in Bug Reports

avatar image

mindfane
3.4k 154 51 271

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ian has asked me to re-post his answer here:

"There appears to be a minor bug in how this is supposed to react. Normally if one actor is set ignore a type, they should simply ignore each other. However,I just got it to work by having each Capsule Component set to ignore the other type. For example:

 Setting the Collision Presets to Custom then...
 Spider is set to be of Object Type Vehicle and ignores Pawn.
 Character is set to Object Type Pawn and ignores Vehicle.

I'd advise creating a custom Object Response in Project Settings -> Collision -> Object Channels, just so you have something that is easily re-usable.

(tested in 4.4)"

more ▼

answered Aug 01 '14 at 01:55 PM

avatar image intoxicat3 Aug 01 '14 at 08:22 PM

Great!

For my opinion this is work around. Any chance to have it working properly (with consequence like in other Actors) in 4.4?

avatar image TJ V ♦♦ STAFF Aug 01 '14 at 09:13 PM

Hi intoxicat3,

Your issue has been submitted and our developers are looking into it. Since 4.4 is right around the corner, if fixed it will most likely it will be part of a future update.

Thanks, TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question