x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Remote compiling requires a server name. Please specify one in the Remote Server Name Setting Field. Not packaging from Windows to IOS in last Unreal versions (4.17-4.21)

Hi,

The Unreal scene that works perfectly from Unreal 4.12 to 4.16 not working NOW with last versions of Unreal. I'm on Windows 10 64bit (dual Xeon, 64 gb RAM, dual Titan XP), with the same certificate and provision and I need to compile the project for IPad Pro 10.5. The App is in developing mode and packaged on one device. Itunes active and working.

I'm working on Windows without Mac (for now) and the project is only BP. I have read all about this error and disabled all the plug-ins inside and outside Unreal but wihtout uccess. Unreal ask me "Remote compiling requires a server name. Please specify one in the Remote Server Name Setting Field."

There was some changes about Unreal politics with Apple? Is it absolutely necessary now to have a Mac to compile for IPad in the last versions of Unreal as BP project only?

Thank you!

Antonio De Lorenzo

Imago Edizioni

www.imaginaction.com

Product Version: UE 4.19
Tags:
more ▼

asked Apr 03 '18 at 12:05 PM in Packaging & Deployment

avatar image

ADL67
11 1 4 7

avatar image Dc43 Apr 20 '18 at 04:59 PM

I'm getting the sane error and could not package my project for ios.

avatar image Alex O ♦♦ STAFF Apr 20 '18 at 05:20 PM

Hello Dc43,

Does restoring your icons to default values (Project Settings -> iOS) allow you to package?

avatar image Harlan87 May 05 '18 at 03:26 PM

I got this problem with 18, i deleted the resoruses folder where the icons are stored. i can not compile if i use any custom icons

avatar image LoneScrapBot Aug 30 '18 at 02:46 AM

Hi, same problem here on 4.18.3.

The issue wasn't present until I attempted to add custom icons and splash screens (.png). Even after reverting to default icons and splash screens I still encounter the issue, however closing the project, then deleting Saved, Intermediate, Build and Binaries folders will allow me to package (after reverting to default icons).

I use no other plugins and have been successfully packaging up until the point where I added custom icons as .png images. After this point the project appears broken in some way.

I was able to create a new project (FPS Template, No starter content, Mobile, Scalable) add my mobile provisions and package it immediately.

Summary of my issue

  • Packaging issue occurs after setting custom icon

  • Reverting to default icons, closing project and removing Saved, Intermediate, Build and Binaries folders seems to restore ability to package temporarily

  • Issue arises again on Project load.

  • Does not occur on a completely new project.

Question: Does anyone else have anything odd happening with the Project Settings > iOS > Marketing Image. in all projects (including blank / empty) I have a red error highlight on this field (see pic) and cannot revert this to default (Error message is "Could not overwrite image file).

alt text

avatar image LoneScrapBot Aug 30 '18 at 03:01 AM

For anyone else hunting for info on packaging and build issues relating to icons / splash screens. There's lots more to it over here:

https://forums.unrealengine.com/development-discussion/ios-development/1384017-418-how-do-i-change-the-ue4-packaging-ios-icon?p=1519078#post1519078

avatar image AFeiYA 3 days ago

Same problem!!! T_T

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

10 answers: sort voted first

Hi, I deleted graphics icon (restore it as default) and Unrel deploy all without problems with 4.19 version too!

ADL

more ▼

answered Apr 05 '18 at 01:06 PM

avatar image

ADL67
11 1 4 7

avatar image youthnick Apr 25 '18 at 03:56 AM

which graphics icon ?

avatar image ADL67 Jan 15 '19 at 09:01 AM

no plug-ins, I have ckecked all from original icons and other check but I have the same problems on 4.21.1!!!! Any1 has resolved this? Thank you Antonio

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I received an answer to my issue in another thread. I was building a AR Template project and it actually requires a Mac to compile, just because it's using the ARKit features.

If a project is not setup to use AR, then it compiles fine. https://answers.unrealengine.com/questions/777855/handheld-ar-template-ios-deployment-from-win10.html

more ▼

answered May 08 '18 at 08:34 PM

avatar image

Niuva
20 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Same here. My target platform is iPhoneX, iOS 11.3.

I get the following error in 4.19 (using win10): "remote compiling requires a server name" ,regardless of what Metal version I try to use tho. It's a fresh mobile AR project with no changes to the project. My certifications and provisions are all valid and iTunes is installed.

more ▼

answered Apr 09 '18 at 06:13 PM

avatar image

Niuva
20 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, I have the same problem. I´m starting project from the scratch, So there is no loaded Icons, just the default ones, I dont use any third party plugins. Certifikats and mobile provision is valid. Still have the same "remote compiling requires a server name" issue. Any suggestions what to try? Thank you

more ▼

answered May 08 '18 at 08:25 PM

avatar image

JV29
1 1

avatar image ERuts Nov 08 '18 at 02:43 PM

Have you already figured it out?

avatar image Saaaaaaaaaamm Nov 23 '18 at 08:18 AM

Finally I find out. In Project Settings>>Pakaging,look right. Under Blueprints, set Blueprint Nativization Method into Disabled.

avatar image Saaaaaaaaaamm Nov 23 '18 at 08:17 AM

Finally I find out. In Project Settings>>Pakaging,look right. Under Blueprints, set Blueprint Nativization Method into Disabled.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yes, I am also facing same problem. Simple AR Template refusing to deploy from Windows PC to iPhone: "remote compiling requires a server name" if everyone is running into the same road block what is the common solution?

more ▼

answered Sep 10 '18 at 07:32 PM

avatar image

Ijaz Naeem Ahmad
1 1 1

avatar image Alex O ♦♦ STAFF Sep 10 '18 at 08:16 PM

Currently with ARKit you will need a Mac with Xcode for remote compiling

avatar image rolfesam Feb 19 '19 at 11:27 PM

is this still the case as of 4.21.1?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1-make sure your project fully blueprint, no c++. 2-disable all third party plugins 3-leave all default enabled plugins to default 4-if you use Crypto disable it uncheck any encrypt marks in Project Settings -> Crypto( clear encryption and signings keys), uncheck Enable Pak Signing. 5-make sure your cert and provision (valid) 6-uncheck Enable Remote Shader Compile in Project setting -> IOS 7-all icons in Project setting -> IOS should be the default icons, you can hack the engine by go to ..\Engine\Build\IOS\Resource\Graphics\ first make a backup of this folder then rename all your icons to the same names in ..\Engine\Build\IOS\Resource\Graphics\ and replace the default engine icons with your icons(they should be the same name and the same size) then go back to engine and go to Project setting -> IOS -> icons and click the little yellow arrow for all icons.

if you follow this infos you will be able to package for IOS from computer in shipping and distribution mode to app store.

more ▼

answered Oct 24 '18 at 11:47 AM

avatar image

Luxury Design
6 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you still can't launch on iOS, and Checked all other answer, TRY THIS:

In Project Settings>>Pakaging,look right. Under Blueprints, set Blueprint Nativization Method into Disabled.

more ▼

answered Nov 23 '18 at 08:19 AM

avatar image

Saaaaaaaaaamm
1 1 1

avatar image qwertyAsdsd Jan 28 '19 at 11:49 AM

Same issue. I have set it to 'disabled'. Still receiving error. PackagingResults: Error: Remote compiling requires a server name. Please specify one in the Remote Server Name settings field.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yeah the problem persists for old projects, it's less present for new native projects with a newer version of Unreal Engine as last 4.21 when you start from scratch and you not activate IOS plug-in as ARkit… we works with Windows 64 pro and PC and we make projects for IOS and Android without great problems...

ADL

more ▼

answered Feb 20 '19 at 09:12 AM

avatar image

ADL67
11 1 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I stumbled on this while trying to compile a plugin. No AR is enabled.

The solution in my case was to edit the .uplugin file and under "Modules", set the "Type" to "Developer"

more ▼

answered Apr 03 '19 at 06:06 PM

avatar image

Lord7even
168 6 12 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is still the case in 4.22 not sure why this happens.

None of this helped. So I made a new project with same engine version, tried to package to IOS and see if it works (it worked) and then migrated the files from old project. This worked for me. (I just selected my 3 maps and pressed migrate and it migrated all the files. Just need to set the project settings a bit and it will work. Or maybe somehow copy the project settings. Also the project has to be blueprint and no custom plugins or any other thing that you need to compile.)

more ▼

answered May 07 '19 at 05:57 PM

avatar image

w2lf
1 3 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question