x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix ShaderCompiler not working in 4.19?

In 4.18.3 I am able to use all of UE4's features just fine. Moving my projects over to 4.19 I noticed that I was getting stuck initialising at 45%; I tried to follow all the usual advice but I've finally been able to work out the problem- 4.19 for some reason on my system is not able to launch the shader compiler workers. When I install 4.19 and open a brand new project, it loads fine, however if I attempt to add shader features (mesh distance fields, clearcoat dual normals) or even alter any of the cached starter content materials, UE4 freezes and stops working. Opening the task manager I can see that no ShaderCompiler processes are created.

I've tried to look but have been unable to find anyone else discussing the ShaderCompiler not launching.

Any advice for getting the ShaderCompiler to work again as it does in 4.18.3?

Product Version: UE 4.19
Tags:
more ▼

asked Apr 04 '18 at 01:10 AM in Using UE4

avatar image

IIIBlackhartIII
66 3 11 13

avatar image Filipe SS Oct 02 '18 at 09:23 PM

Has anyone figured out how to solve this? I am in version 4.20 and I do not have Incredibuild installed on the machine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

For anyone coming to this thread at a later date, I found a solution in my case!

For me, the solution was uninstalling a third-party development tool called "IncrediBuild".

This was a tool included in one of Visual Studio's coding packages who's background service interfered with proper operation of Unreal Engine.

I was able to track this issue down with help from the members on the discord server when attempting to build a version of the engine from GitHub source and the build kept failing as a result of IncrediBuild. Whatever benefits this service purports to offer, my current suggestion if you encounter a similar error in your UE4 install is to remove this tool from your system.

more ▼

answered Apr 05 '18 at 06:24 AM

avatar image

IIIBlackhartIII
66 3 11 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Delete the temp folders and saved folder. btw, 45% is standard, it just takes a long time to compile. If you still' cant get it to compile, change material in any of the objects in the map. It will re compile, or a quick light bake?

more ▼

answered Apr 04 '18 at 01:38 AM

avatar image

shrikky
213 6 9 12

avatar image IIIBlackhartIII Apr 04 '18 at 01:47 AM

I understand that getting stuck at 45% for a little while is normal, but I know that my current situation is not normal. I posted a thread about this before. I'm running an i7-7700k with a GTX 1080TI on an SSD... opening a blank project in 4.18.3 with starter content I can change the materials, save, look at my task manager and see ShaderCompiler processes open up, and it works. If I enable Mesh Distance Fields or Clearcoat Normals it gets stuck at 45% for a minute, in the task manager I see ShaderCompiler threads, and then it opens. 4.19 I do not see ShaderCompiler threads launching. If I open a blank project with starter content and attempt to edit the material it freezes and doesn't finish saving, and no ShaderCompilers appear. As far as I can tell, in 4.18.3 ShaderCompiler is working as intended, in 4.19 on the same computer with no changes the ShaderCompiler isn't launching.

I was testing with a friend earlier this evening and we both did a clean install of 4.19 and did the same test- open a blank project with starter content and attempt to edit a material. On my computer it freezes, on their computer he could see ShaderCompilers open in task manager (as I could see in 4.18.3) and their material finishes saving. My computer 4.19 does not seem work as intended, ShaderCompilers don't launch.

avatar image shrikky Apr 04 '18 at 03:44 PM
  1. Check your graphics card drivers.

  2. Check or clear up the config files in UE4 project

  3. Check your version control if you have any, change the entire project to not read-only.

Mainly, do you have any external plugins, like Substance or other stuff installed in the 4.19 or in the 4.18 that could make a difference?

What happens when you open existing 4.18.3 project in 4.19 as opposed to creating a new one?

avatar image IIIBlackhartIII Apr 04 '18 at 06:33 PM

My graphics card drivers are up to date. Nvidia drivers currently 391.35; I'm also able to use all other programs with GPU acceleration just fine- playing some FC5 and BF1 to test it, opened Premiere Pro, opened Blender and did a quick GPU render. All working.

What project files should I be looking at? To test the engine what I have been doing to ensure that 1) I don't corrupt my existing projects and 2) I'm not introducing possible issues with any of the assets I created in my projects- I've been launching the editor and creating a new blank project w/starter content, and then attempting to edit one of the materials in that project.

I'll attach some images to show what's happening.

In 4.18.3 if I open a blank project and go to edit a material, with the task manager open I can see my CPU starts getting hit hard and it spawns some "ShaderCompiler" threads.

alt text

In 4.18.3 while these ShaderCompiler threads are running I also get the little notification box in the bottom right letting me know the progress of those shaders recompiling.

alt text

In 4.19.0 for some reason I do not get any ShaderCompilers, my CPU doesn't appear to be doing any extra work, and I don't get a progress box in the bottom right. It simply freezes as if the software is getting confused trying to create those ShaderCompiler threads and for some reason can't.

alt text

Plugins- I usually have the Substance Plugin installed, and I also need 4.19 because I need the new Datasmith tool for work, however for the sake of testing I removed those plugins. It made no difference, 4.19 still doesn't create ShaderCompilers.

I'm also not sure what you mean about version control- I'm not making an engine from source (I have done that before to play with Nvidia Gameworks branches)- I'm currently just trying to use the version from the Epic Games launcher.

avatar image vorp May 31 '18 at 06:43 PM

I'm seeing the exact same behavior with almost the same setup (Github 4.19 source, incredibuild just installed, etc). Is there any known solution to this? Would love to hear! Thanks.

avatar image IIIBlackhartIII May 31 '18 at 06:48 PM

AFAIK the only solution currently is uninstall IncrediBuild.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question