x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VS Code Build Error: Cant find Target Rules file

Trying to use VSCode with UE 4.19, made a C++ Blank Project, in the default "Documents/Unreal Projects/ " directory, named StateManagerProject.

In the debug menu running, StateManagerProjectEditor (Development), launch task. The error comes from the, StateManagerProjectEditor Win64 Development Build, pre launch task:

 Creating makefile for StateManagerProjectEditor (no existing makefile)
 
 ERROR: Couldnt find target rules file for target 'StateManagerProjectEditor' in
  rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null
 '.
        Location: C:\Program Files\Epic Games\UE_4.19\Engine\Intermediate\Build\B
 uildRules\UE4Rules.dll
        Target rules found:
         UE4Editor - C:\Program Files\Epic Games\UE_4.19\Engine\Source\UE4Editor.
 Target.cs
         UE4Game - C:\Program Files\Epic Games\UE_4.19\Engine\Source\UE4Game.Targ
 et.cs
         UnrealHeaderTool - C:\Program Files\Epic Games\UE_4.19\Engine\Source\Pro
 grams\UnrealHeaderTool\UnrealHeaderTool.Target.cs
 
 The terminal process terminated with exit code: 5


EDIT: Tried making the same C++ Blank Project but changed the directory to "Documents/UnrealProjects/" without a space, and everything compiled as it should.

Fix: Remove Space from Unreal Projects?

Product Version: UE 4.19
Tags:
more ▼

asked Apr 04 '18 at 04:39 AM in Everything Else

avatar image

Diddykonga
100 14 18 25

avatar image † SG † Apr 23 '18 at 03:58 AM

I can confirm whitespaces are the issue. Tested this on 4.19.1 with a path including spaces (same error) and when removed, the tasks work as intended. The path is most likely being split at some point, I'll dig into it further.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question