x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mixamo character cant be recorded using the sequence recorder

When recording a mixamo character in my unreal scene, upon playing back the recording the character is rotated on its side and when i try and rotate it back in the sequence recorder the bottom half of the mesh becomes distorted like its being pulled down by something. However, it is also distorted when on its side too. Even animations attached to the character like a walk are played as normal on its side, so it walks facing the floor.

Is there a fix for this and why is it doing this?

Product Version: UE 4.17
Tags:
more ▼

asked Apr 06 '18 at 02:22 PM in Using UE4

avatar image

pokegirl55
8 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

I know this is a bit late but in case you are still running into this issue or someone else come across the same issue, the reason the recording looks distorted and messed up is that Mixamo skeletons do not have a root bone by default.

By that I mean the first bone in their skeleton is the hips which are moving around rather than having a dummy bone at 0,0,0 that all the other bones move relative to. Sequence Recorder defaults to removing motion on the root bone which is usually what you want however in the case of Mixamo skeletons it will remove all motion on the hips causing this to remain in place while the other bones move away from it leaving your geometry very deformed.

There are two solutions here. The first solution, which is the fastest, is to tell Sequence Recorder to not remove Root Motion. You can find this option under Default Animation Settings in Sequence Recorder. This will get your animation recording properly however may lead to issues if you try and use this animation elsewhere in your project.

The second solution is my preferred but requires a change to your workflow. When you get your skeleton from Mixamo you can modify it to contain a new bone at 0,0,0 and parent the existing skeleton below that bone. This will allow Sequence Recorder to correctly record without requiring the use of Root Motion.

You can find more information on what Root Motion is and how to work with it in our docs page here: https://docs.unrealengine.com/en-us/Engine/Animation/RootMotion

Hope this helps,

Dave

more ▼

answered Jul 03 '18 at 11:35 AM

avatar image

Aeryll STAFF
26 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question