x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Get all actors of class is empty

Hey there, I have an array of classes as a variable in my blueprint called "FearObjects" filled with two classes: alt text

I want to get all actors of the class at the second position of this array "BP_ScaryChair" alt text however the Out Actors array has a length of 0 despite of me having several objects of the type "BP_ScaryChair" in my level. When I ask specific for "Get all actors of class" and select BP_ScaryChair it works and I get all Actors. Is this a bug or am I doing something wrong? Thank you!

Product Version: Not Selected
Tags:
classarray.png (7.7 kB)
doesnt work.png (39.1 kB)
more ▼

asked Aug 01 '14 at 03:13 PM in Blueprint Scripting

avatar image

NoMonkey89
139 9 14 21

avatar image Gooner44 Aug 01 '14 at 10:23 PM

Not sure if related but I have a similar issue. I'm trying to get objects I can see in the level and change their enum setting from a blutility BP. I would assume it was an issue with blutility being experimental except for the fact I have a near identical one working just asking for a different class. What is the base class you are trying to get? For me an actor class works, but it's the character class that returns 0 results.

Hope that sparks an idea from someone.

avatar image NoMonkey89 Aug 02 '14 at 02:25 PM

The BP_ScaryChair and BP_ScaryStatue are children of BP_ScaryObject which is a child of Actor.

avatar image erkyle Aug 08 '16 at 05:04 PM

Hi, I have the exact same issue, but I don't know how to fix it. I'm using the node in a Level BP, when the player overlap one trigger, here's a screenshot

alt text

I'm on 4.12.5, I'm doing somthing wrong but I'cant see it. Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

When are you running the code? Maybe the actors aren't instantiated yet.

more ▼

answered Aug 02 '14 at 01:55 AM

avatar image

cgrebeld
497 25 16 33

avatar image NoMonkey89 Aug 02 '14 at 02:22 PM

It's at Event Begin Play but as I said, when I ask directly for a specific class instead of using the array element it works: alt text

this works.png (21.4 kB)
avatar image cgrebeld Aug 03 '14 at 12:32 AM

What's the type of the Fear Objects variable? Maybe try making it more or less specific.

avatar image NoMonkey89 Aug 03 '14 at 05:52 PM

It's an array of 'class ScaryObject'. But today I tried it with no changes at all and it works as it should. So thank you for trying to help me :-)

avatar image eXi Aug 03 '14 at 08:05 PM

Could you mark the question as answered? :D I read everything to help you and at the end i saw that it's already solved.

avatar image NoMonkey89 Aug 03 '14 at 08:45 PM

Sure thing, i didnt marked it as resolved because there isn't an answer for Gooner44's problem but I guess he should make a question on his own.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question