x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Navmesh doesn't change on Rebuild Navigation

Hi,

So I'm experiencing a problem where I spawn Actors into a game, like ressources and buildings. After spawning these, I'm trying to execute the "rebuild navigation" command via "Execute Console Command". This doesn't, seemingly, change anything about the Navmesh. When I put the Actor into the scene manually before starting the game, it does what it's supposed to do and interacts with the navmesh.

I have set navmesh generation to dynamic modifiers only. In the building and ressources blueprint i have set "can ever affect navigation" to true and it didn't help at all.

When setting Runtime generation to Dynamic the ai goes apeshit and it seems like it's trying to find a new path every frame or so, basically it's wiggling it's way to the target very slowly but never really reaches it or rather never really triggers "on success", which hinders me from trying it in dynamic mode.

Is the problem connected to the ai not being able to find the path in dynamic mode?

Thank you very much for every helpful hint you got for me ^^ attached you'll find the problematic scripts.

alt text

Product Version: UE 4.19
Tags:
picture1.png (18.9 kB)
picture2.png (267.1 kB)
picture3.png (301.2 kB)
more ▼

asked Apr 10 '18 at 07:12 AM in Using UE4

avatar image

Nickcha
0 2 6

avatar image Nickcha Apr 10 '18 at 04:33 PM

Noone out there who could help me with this?

avatar image Nickcha Apr 13 '18 at 05:55 PM

Still noone?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question