x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issues with exporting/importing blender to ue4

I seem to be having a problem with exporting/importing with textures from blender to ue4 i have watched videos and done lots of reading but what ever i do when i import to ue4 my textures are all white. I will go over my settings and workflow in detail sorry its long winded but hopefully someone can point out where i am going wrong.

BLENDER SETTINGS- Cycles render GPU compute sampling - render 500 light paths min-0 max-4 all other settings are default.

I first create my object and add the texture i want with the node editor using difuse. I then split my screen open UV editor and create a new image. Then i enter edit mode tap U then press the smart UV Unwrap which then gives me the boxes in the UV editor. I then open the node editor in another split screen ensure that the image texture is selected. go to render tab then i do a combined bake without changing any settings. once that has done the texture shows up in the UV editor and then i save that image file.

I then go to export as an FBX i click to only export the mesh change smoothing to edges, and then export. i have tried other settings but nothing changes every time i import the FBX to UE4 i get the static mesh which only shows as white and i also get the texture files too but they are also white and i cant figure out why. have i missed something do i have a bug of some type? any help would be greatly appreciated. if you require more info or screen shots of anything please ask.

Product Version: UE 4.19
Tags:
more ▼

asked Apr 11 '18 at 03:45 PM in Using UE4

avatar image

mattyi85
16 1 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

if you want the textures to be imported from blender you will need to actually make the images into a texture in blender. i just tested it and what i did was to go to the texture tab (checkerboard one) then make the type image or movie, then went to the image section and selected my image. images are just images in blender unless you make them into textures.

alt text

capture.png (111.4 kB)
more ▼

answered Apr 11 '18 at 04:16 PM

avatar image

ThompsonN13
10.1k 33 10 25

avatar image mattyi85 Apr 11 '18 at 06:40 PM

I had already checked that it was in the textures tab. it adds it in there from the node editor as you can see from the blender screenshot "CubeTex" (baked image) is in the texture tab the picture is saved also. But as you can see from the UE4 screen shot the CubeTex mesh and the material are both white. even if i double click them to look at their properties there is nothing in there showing any textures have been sent over.

alt text

alt text

screenshot-4.png (972.3 kB)
screenshot-5.png (1.2 MB)
avatar image ThompsonN13 Apr 12 '18 at 12:05 AM

do you have import textures checked on the import options?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Blender part seems fine for me (but i don't work with cycles tbh). In UV editor open your texture, click on "image" then "save as image" (or just press F3 - by default) then you can chose file format on the left. Not sure which is best, but .png should work. Save somewhere (desktop for example) and open it by double click. If you can see you texture - we are fine at this point. Small note - make sure your texture size is correct, for example 512x512, 1024x1024, 2048x2048 etc. Now when you have imported texture and your mesh into UE4 place your cube somewhere in your level, then make a new material and open it by double click. Drag your texture from content browser into material editor, connect texture into "base color" and save your material. At this point your material shouldn't be white. Last thing is to drag your material directly on your cube which you placed somewhere before.

You can also put some screenshots from material editor and window which popup when you double click your texture in content browser if there is still some problem.

more ▼

answered Apr 12 '18 at 01:01 AM

avatar image

Velu12
125 3 7 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sorry for slow reply completely forgot about this to be honest. I already knew about baking the textures saving the image then applying it through UE4 but that in itself comes with issues like the lighting and shadows are also baked from the blender light source. that isnt the effect i wanted as i want ue4 to control the lighting and shadows.

This seems to be an issue with blender as i have seen other people move over textures with the mesh. I myself have also managed to get it to work but only on occasion it does seem very tempermental. The only workaround i seem to be able to find is to create everything in cycles render then go into blender render and assign the textures within that then move them over which seems to work 99% of the time.

more ▼

answered May 20 '18 at 12:28 PM

avatar image

mattyi85
16 1 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question