x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Google Play Services Failing / Been Trying for Days

I'm basically at my wit's end here. I'm trying to use google play services in my game, but it is turning out to be so incredibly difficult. I would be so grateful to anyone who would be willing to throw out anything to try. I'll be as detailed as I can. If I leave anything out let me know. I've done all this multiple times, starting from the ground up because there doesn't seem to be a unified resource on how to do this.

Here's a list of everything I've done.

-"enable google play services" checked in project

-Generate SHA1 fingerprint

-Include SHA1 fingerprint in ue4 project for signing and creating a client ID

-Included games app ID in project settings

-"Distribution" box is checked, so it doesn't use debug fingerprint

-Included google license key in my ue4 project settings

-ensured .xml file was updated correctly

-Used the same package name in project, in google play services and app dashboard.

-Made a privacy agreement and linked to project

-Linked application to services and completed services setup. All green check marks

-Set up leaderboards from google services and added leaderboards

-Added leaderboard id's to unreal project

-Connected list of testers, including my own email, allowed that list in services

-Enabled the following APIs

 Google Cloud Messaging for Android\

 Google Cloud Pub/Sub

 Google Cloud User Accounts

 Google Play Android Developer API

 Google Play Game Management

 Google Play Game Services

 Google+ API


-Linked to google api, same package name and sha1 fingerprint

-Added Server Key to google api

-Linked privacy policy in google api

-Included the following in the packaging

-added the following to manifest node in the ue4 android project settings:

 com.google.android.gms.games.APP_ID="@string/app_id"

 com.google.android.gms.appstate.APP_ID="@string/app_id"

-added the following to "extra permissions" right next to the information above:

 com.android.vending.BILLING

 android.permission.INTERNET

 android.permission.GET_ACCOUNTS

 android.permission.USE_CREDENTIALS


Is there something I'm supposed to do with the api keys? I mean, I am just stumped. I have done sooooo much reading about how to do this and I think this is all I need to do, and it should work. I've basically started all the way over just to make sure I did everything exactly as instructed.

But when I call "Show external login UI", I get the "connecting to google play games" pop-up, then a loading circle, then it fails. I feel like I've tried everything. Is there something else I need to include in my blueprints?

Please, anyone who has even a little experience with this, help. I'll post pictures or be as specific as requested.

Product Version: UE 4.19
Tags:
more ▼

asked Apr 12 '18 at 09:17 AM in Packaging & Deployment

avatar image

geekTechnique
83 2 7 14

avatar image geekTechnique Apr 13 '18 at 06:13 AM

Shameless self bump. What do I have to do to get someone to help me? I'm desperate.

avatar image SHAINPAIN May 10 '18 at 02:57 PM

So how did you manage to generate your SHA1 fingerprint. I keep trying to get it through the command prompt using keytool -list -keystore D:...\UE4\VMobile_VR\Build\Android> as the file path but it keeps kicking me back that the syntax is incorrect. Any help would be greatly appreciated.

avatar image Cyrille26 May 10 '18 at 09:14 PM

Before to link a application, generate a file .keystore and after you can found the SHA1 fingerprint. Here you have a link that explain 2 steps ( https://coderwall.com/p/r09hoq/android-generate-release-debug-keystores ) When you have the SHA1 fingerprint, you can link the api google play service with your application. That's all.

avatar image Cyrille26 Apr 14 '18 at 09:40 PM

Hi, i have the same problem like you. The problem come from "Show external login UI". I found this link ( https://developers.google.com/games/services/android/troubleshooting ) It can help to found the problem with the google service api.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi, I had same problem
Still struggling with the leaderboards∾hievments but I could login.
Below solution will only work if you package your project in SHIPPING
First there is 2 concept of signing.

  • for upload

  • for using google API's

alt text

to communicate with google API you need to use upper SHA-1 for Outh-2 requester(below)
I can successfully login. But cannot go further.

alt text

Another solution is not open app signing at googleplay side. I hope both helps, If you have solution about leaderboard and such stuff, please share with me.

Cheers

googleapisign.png (96.6 kB)
googleapisign2.png (153.8 kB)
more ▼

answered Jun 21 '18 at 07:16 AM

avatar image

ForRedrain
21 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ok, I had same problem for past 4 days, this is how I fixed it:

Deleted game from app store and game service(unpublished)

Remade it step by step guide I found, but here is where the problem came from:

When you sign your app with sha1 fingerprint from keystore: Make sure you get the SHA1 USING THE PATH IN ANDROID=>BUILD=>project.keystore Not the one in c/user/.keystore.

So when you generate your keystore, place it in build=>android, and get the SHA1 FROM THERE. Hope it helps.

more ▼

answered Nov 23 '18 at 11:38 PM

avatar image

Sampuig12
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question