x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Multiplayer standalone doesn't find session anymore. No changes to project or engine

When I test my project (multiple windows, standalone) and host (listen server, LAN) in one window, I can't find the session in the others. Now, it could be a mistake by me, right? But it worked before, always, reliably.

I continued with a copy of this project in a newer engine version and realized, that find sessions didn't work anymore. So I went back to the older versions of the project, that definitely worked as I stopped with them.

The host is successful (I use advanced sessions plugin, the default unreal engine nodes don't make a difference, I thried it), the find sessions is successful, too. There are no errors.

Strange to me: The standalone windows work with an export of this project over network to another computer (both server/client constellations), but the standalone windows don't communicate among themselves on one computer (I also tried to test the project on another computer, same network. Same result).

So, I can export and use it, since I normally don't want to play multiple instances on one computer, but I need to be able to test it in the engine for developing.

Because I'm not a programmer and at the moment not capable of c++, I don't know, what's going on and how to solve it, since this seems really strange to me because it worked before and I didn't change anything. Actually I copied the project several times and none of these old projects find sessions anymore (UE 4.15, 4.17., 4.18, 4.19).

Thank you for your help, apsodi

Product Version: UE 4.17
Tags:
more ▼

asked Apr 12 '18 at 05:45 PM in Blueprint Scripting

avatar image

apsodi
25 2 2 9

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question