x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Panner Material lower fps than gameplay?

Hi there, I have a strange effect since always (oldest Version ue4.15). I have a 2d game for mobile where my Background is rendered on a plane infront of my camera,which does not move. In order to achieve an optical illusion of moving, i have this star background material with a panner node.(and other materials which work the same way. But when I test on my android device (SONY Xperia z1 compact) I experience the strang effect that my gameplay(character,enemies movieng etc) is all running with 60fps while my background is running with it's own fps and choppy! But the wors thing is that this is happenng just SOMETIMES, but also ALWAYS after debugging with usb and starting the game first time after debugging. I'ts very annoying and I don't have any clue how to solve this problem. I'm pre release so any help would be appreciable. alt text

Product Version: UE 4.18
Tags:
material.png (392.3 kB)
more ▼

asked Apr 13 '18 at 12:42 PM in Rendering

avatar image

Aleksandro
207 7 16 15

avatar image Arty-McLabin Apr 13 '18 at 01:35 PM

looks like the only reason behind it could be the material setup properties, not the graph.

can you check these? they appear a few widgets under the preview sphere by default

avatar image Aleksandro Apr 13 '18 at 03:59 PM

alt text

These are all my Settings in my spacematerial. I really have no clue what to check or change.

avatar image Arty-McLabin Apr 13 '18 at 04:12 PM

i give up. everything looks good to me.
i hope somebody with more knowledge about material frame-rates help you.

avatar image Aleksandro Apr 14 '18 at 03:41 PM

Oh man. Thanks for taking a look. Still no solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Yo, I found the solution: Just link a Time node to the Time Input of the panner and check the "period" box in time and set the value of the period 1/Speed from panner node. Found the solution in the docs: https://docs.unrealengine.com/en-us/Platforms/Mobile/Materials Issue: "Material Animation with Time Expressions looks choppy but framerate is good elsewhere."

more ▼

answered Apr 16 '18 at 06:13 PM

avatar image

Aleksandro
207 7 16 15

avatar image Arty-McLabin Apr 17 '18 at 02:47 PM

great, can you mark it completed then?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question