x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My Textures Brighten When Added to Material Editor

A bit of an odd problem here. Using 1.9.1 for the first time (I don't usually use versions this up to date due to bugs like this) But my textures go an odd bright colour when added to the material editor.

The textures are bitmaps exported out of Substance Designer. This is the first time I have used Designer to create textures and add them to Ue4.

I have a LOT of textures from designer and they all suffer this problem. There is a lot to go back and change, so I am hoping this is just a simple in-engine setting.

Normal Maps also seem to be affected, it is unclear with the other maps.

Any clues? Is this a version bug? Or has it been around for a while, if so, how would I go about fixing this?

alt text

Product Version: UE 4.19
Tags:
materialproblem.png (719.1 kB)
more ▼

asked Apr 16 '18 at 12:48 PM in Using UE4

avatar image

Raxs_Slayer
168 8 15 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Saving as .png might have had some compression which would cause this when the engine re-compresses it. So yes, try uncompressed .TGA and let's see if it fixes this.

more ▼

answered Apr 23 '18 at 04:56 PM

avatar image

duderseb
503 2 9 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Are you importing these via the Substance plugin? If not, one thing you can check is that your texture maps are using the correct compression and sRGB settings. Just double-click any texture asset and check here:

alt text

Normally you should have: - Diffuse/Albedo/Color textures set to Default compression and sRGB enabled. - Channel-packed textures set to Masks compression and sRGB disabled. - Normal maps set to DXT5 and sRGB disabled.

00.jpg (58.2 kB)
more ▼

answered Apr 18 '18 at 09:01 PM

avatar image

duderseb
503 2 9 7

avatar image Raxs_Slayer Apr 18 '18 at 09:12 PM

Hello duderseb, thanks for the reply.

I looked into it an unfortunately it doesn't yield the results I am looking for. As you can see from this screenshot, if I tick the box, it actually makes the texture in the preview look washed out and wrong (Just like it looked when I drag it into the material preview, but now also in the texture preview after double clicking).

So sadly the problem doesn't go away. It just seems to cause the issue to occur one step back.

I am exporting my textures out of substance as bitmaps, and using those. The .sbar files in the plugin dont seem to work as intended, so I had to abandon those.

Do you have any other ideas why this may happen?

Cheers

alt text

materialsystem.png (733.6 kB)
avatar image duderseb Apr 18 '18 at 09:34 PM

Could be the export file format out of Designer... are you using .tga?

avatar image Raxs_Slayer Apr 19 '18 at 11:01 AM

Substance exported them out as PNG I think.

Is .tga advised?

avatar image duderseb Apr 19 '18 at 02:16 PM

The .png might have had some compression which would cause this. So yes, try .tga and let's see if it fixes this.

avatar image Raxs_Slayer Apr 23 '18 at 09:22 AM

Thanks for the reply. Sorry for the Delayed response, it's been a busy week. I will be sure to try this out within the next few days and let you know how it goes (: Thanks again.

avatar image Raxs_Slayer Apr 23 '18 at 11:49 AM

Just tried it. Works perfectly. Thank you so much. If you could post your solution into a new answer I will mark it as accepted (:

avatar image duderseb Apr 23 '18 at 04:55 PM

Great! Will do ☺

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question