x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UI Widget appears with faded color

I have a blueprint with a widget component, which is using a Widget Class of my own making. The widget looks correctly-colored in the editor, but has odd, faded colors (yet fully-opaque) at runtime.

My widget has a canvas with some images on it. In an attempt to go overkill…

  • The root widget has both the Color and Opacity and Foreground Color set to bright red [RGBA(1,0,0,1)]

  • Each image has both the Tint and the Color and Opacity set to bright red.

The images are white with alpha, and in the editor they are, predictably and desirably, bright red. However, at runtime the widgets shown by my blueprint are massively faded: RGB(0.59, 0.47, 0.47, 1)

The Material for the Widget component is currently set to Widget3DPassthrough_Translucent. (However, it does not seem to matter what material I set here; the widgets always render the same, even picking a material that has a solid, opaque, ugly texture filling the UV space.)

alt text

Anyone have any guesses as to what setting I'm missing?

Product Version: UE 4.18
Tags:
redbracket.png (134.0 kB)
more ▼

asked Apr 16 '18 at 04:39 PM in Using UE4

avatar image

Gavin.Kistner
94 3 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found it: the root Canvas panel was set to "Enabled: false", which was causing it to procedurally alter the appearance of all attached widgets.

more ▼

answered Apr 16 '18 at 08:42 PM

avatar image

Gavin.Kistner
94 3 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question