x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging project Fails > Access denied

I regularly package and build my projects for windows(64) to check for any problems. This has always worked for me just fine until today. Now if I package or cook anything I get: Running AutomationTool...>Access denied>BUILD FAILED (full error log attached)

I can not find any particular thing I've changed which might have caused this problem. This happened while working on blueprints (All projects I have tried are blueprint only). I have the same problem on all engine versions currently installed(4.17.2, 4.18.3, 4.19.1), on all custom or brand new template projects (first person template without change for instance)


So far I have tried:

  • Reinstall unreal engine 4

  • Deleting of project files : "Saved" and "Intermediate" folder on current project

  • Updating to latest engine version

  • Setting all package supported platforms to only "Desktop" or "Windows" or both.

Made sure all files below have read only turned off:

  • \AppData\Local\EpicGamesLauncher\

  • \AppData\Local\UnrealEngine\

  • \AppData\Local\UnrealEngineLauncher\

  • \AppData\Roaming\Unreal Engine\


Other info:

  • Windows 7 x86 (Admin)

  • No Source control

  • Projects compile and run in editor succesfully

  • AV Turned off


I have not found a solution to this problem or even pinpointed what causes it. Because I encounter this error for all projects and all engine versions, I wonder if my epic account might be the cause yet this is not clear.

I'm hoping that there is someone out there who might have a solution.

Product Version: UE 4.19
Tags:
more ▼

asked Apr 18 '18 at 07:42 PM in Packaging & Deployment

avatar image

Ryan7865
1 1 2

avatar image Ryan7865 Apr 22 '18 at 08:10 PM

Bump, I have not yet found a solution.

avatar image winrarz Apr 23 '18 at 05:44 AM

Have you tried changing the build directory to another HDD? It looks like you've just built into the project directory. This may give some more insight.

avatar image Ryan7865 Apr 23 '18 at 09:35 AM

Thanks for your reply. I've tried building on different HDD without success. Because the output log shows Running AutomationTool... first, then immediately after Access denied. And if I package a new project in a empty directory it's the same. This makes me think it's something with the editor or engine itself. I'm not sure though.

avatar image Ryan7865 Apr 29 '18 at 11:34 AM

Bump again

avatar image BeefSalad4325 May 06 '18 at 12:21 PM

Bump, still not found a solution.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I cannot spot why the error might be occurring if it used to package successfully before and suddenly not anymore. I would suggest reinstalling/repairing. DotNet, VC++, DxDiag etc. Also, if you have any antivirus on, try turning it off while packaging. That might be causing the access denied error.

more ▼

answered May 07 '18 at 06:30 AM

avatar image

SHOBBIT
650 12 13 27

avatar image BeefSalad4325 May 07 '18 at 11:40 AM

Thx for your suggestions, I'l have a look and see if this solves the problem

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question