x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Translucent Material Receive and Cast Shadows

Translucent Material Receive and Cast Shadows

Engine version: 4.19.1

I have searched and tried many different things and still have not found a solution for my problem. Thus I am here.

Ideally I want to take a static mesh like a tree and fade it out if its in the way of the camera. Since the tree receives and casts shadows, I want to make sure the transparent material that is swapped to the tree also receives and casts those same shadows.

The problem is that I can't even make a basic transparent cube cast and receive shadows. I have set its material to Blend Mode: Translucent, Lighting Mode: Surface TranslucencyVolume. Then on the mesh in the world, I have set Volumetric Translucent Shadow to true.

The result I have with a single stationary directional light and the mesh set to Mobility: Static after building lighting is not receiving shadows or casting shadows. If I made the mesh Moveable which forced Dynamic lighting, then I can get it to at least cast a shadow, but not receive any. I was expecting to be able to both cast and receive shadows with both baked or dynamic lighting. How do I accomplish this?

P.S. I also tried setting World Settings->Lighting->Volume Lighting Method to Sparse Volume Lighting Samples as well as the default Volumetric Lightmap setting without success.

alt text

alt text

Product Version: UE 4.19
Tags:
trans1.png (531.8 kB)
trans2.png (854.1 kB)
more ▼

asked Apr 22 '18 at 08:48 AM in Rendering

avatar image

Syclone3D
8 3 5 8

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Material: Blend Mode: Translucent Two-Sided: True Lighting Mode: Surface Translucency Volume

Then for your mesh placed in the level select it. In it's Details Panel make sure that Volumetric Translucent Shadow is set to True.

more ▼

answered Sep 08 '18 at 10:27 AM

avatar image

Hlaing Min
1 1

(comments are locked)
10|2000 characters needed characters left

Hi, does this work with skylight (hdri) too or only with directional lights?

more ▼

answered Nov 28 '18 at 03:07 PM

avatar image

ron25
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question