x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particles not killed on collision within a blueprint...

Currently I have a moving light with dust particles and a cone shaped mesh for them to collide with in the same blueprint. The idea is to kill off dust particles that aren't in the light cone anymore as it points in a different direction. I've added collision modules to my particle system and they collide with world geometry just fine, but are ignoring the command to be killed when they collide with the mesh within the blueprint, no matter what settings I apply.

Product Version: Not Selected
Tags:
more ▼

asked Aug 02 '14 at 07:37 PM in Using UE4

avatar image

swiss_cheese9797
168 33 58 75

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Download and open Content Examples from the Marketplace. Open Level - Effects.umap Go to Exhibit 1.5

Been awhile since I was in the Effects example. That thing amazes me every time I go in there.

more ▼

answered Aug 03 '14 at 04:20 AM

avatar image

Zeustiak
1.8k 130 68 110

avatar image swiss_cheese9797 Aug 03 '14 at 01:13 PM

Thanks. I just looked though and there's no blueprint there. The particle system and the static meshes the particles are colliding with are on their own in the world. The setup I'm working on calls for static meshes and particles colliding with them to be in the same blueprint but so far I can't get them to collide with a mesh in the same blueprint.

avatar image swiss_cheese9797 Aug 03 '14 at 01:28 PM

So I pot the components form 1.5 and put them in the character blueprint and did some tweaking. They are colliding, except that they are ignoring the kill command of the collision module. I have the maxcollisions set to 1 and the action set to kill but theyre all just bouncing like normal. On it's own in the world, the particle system's particles are being killed when they collide with the floor just fine, but in a blueprint the kill command is being ignored.

(comments are locked)
10|2000 characters needed characters left

Basically I am posting it here because its first query in google search about this issue. So basically I'm answering it to prevent others to struggle with it:

In Particle System tab, whenever you want to include particle collision within blueprint, just untick the box "Ignore Source Actor" in Particle's "Actor Collision".

Regards . alt text

collision.png (29.6 kB)
more ▼

answered Jan 03 '19 at 01:11 PM

avatar image

laonfis
1 1 3

avatar image cosmic613 Mar 25 '19 at 02:57 PM

Iaonfis, I am having the same issue as OP and can find no such box to uncheck in 4.19.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question