x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

hitbox detection bad on clients

as you can see from this video it appears that the bullets are not colliding with the animated mesh but rather in default a pose. do you have any idea why this would happen and what I could do to potentially fix it? also, good sources for networking in ue4 would be appreciated.

https://www.youtube.com/watch?v=vue74uCiyus&feature=youtu.be here is the video demonstrating my problem. it works fine as the server on non-dedicated server btw

Product Version: UE 4.19
Tags:
more ▼

asked Apr 27 '18 at 12:35 PM in Blueprint Scripting

avatar image

Atornity
234 3 13 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

the solution is to change "mesh component update flag" in your skeletal mesh properties to "always tick bones and refresh bones". i think the server is not updating the bones because it's not rendering it

more ▼

answered May 04 '18 at 05:20 PM

avatar image

Atornity
234 3 13 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The only answers I could give to you is that:

  1. Your Projectiles do collide with the Character capsule and not with your Skeletal Mesh or

  2. Your Projectile flies in a wrong direction or your LineTrace is set up wrong

more ▼

answered Apr 28 '18 at 08:58 PM

avatar image

Norishou
21 1 5

avatar image Atornity Apr 29 '18 at 02:45 AM

I'm indeed using projectiles and I first thought it would be a problem with them but I created a new blank 3d person project with just a simple line trace and I'm getting exactly the same issue. only on dedicated server tho which is weird. everything works as long as the server is playing.

no, it's not colliding with the capsule, the collision on that work's fine. that leads me to believe it's related to the anim blueprint although I left it on default on my new project.

avatar image Norishou Apr 29 '18 at 07:08 AM

Fan you Maybe Show a Screenshot of the blueprint where you make the linetrace?

avatar image Atornity Apr 29 '18 at 12:46 PM
capture.png (132.6 kB)
avatar image Norishou Apr 29 '18 at 02:34 PM

I use the forward vector every time instead of the control rotation, but I dont know if that is the problem.

avatar image Atornity Apr 29 '18 at 03:03 PM

initially, I used the forward vector. I just tested with control rotation as it's replicated but it shouldn't make a difference as I'm feeding it through the function anyway. and it didn't

edit: I realize that you might have meant rotationxvector. I'm pretty sure it's exactly the same as forward vector, anyway it gave the same results.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question