x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.19.1 Move & Scale widgets not rendering in Lit mode

I recently upgraded a 4.18.3 project to 4.19.1, and the Move & Scale widgets are not rendering correctly in the editor in Lit & Unlit modes.

You can see the widget rendering on top of the light icon here. alt text

Widget is fine if you switch to Wireframe mode: alt text

Rotate widget edges appear, but the center does not: alt text

Project settings: - this is a VR project, with target platform set to Mobile and 3d/2d Scalable, but is not a mobile project - Uses Forward Rendering and Instanced Stereo.

Steps taken based on older questions with this problem (https://answers.unrealengine.com/questions/30353/move-scale-rotate.html):

  • I'm not in Game mode

  • mobile preview is not on (preview set to Shader Model 5)

  • mobile HDR is off

  • Show Transform Widget is On

  • Deleting the Saved and Intermediate folders doesn't fix the problem

  • I've reset all of the settings I can think of

  • I've deleted the project's DerivedDataCache and the one for 4.18 and 4.19 in app data / user to force rebuild shaders

This issue occurs in all project maps, even blank maps with no lighting objects, and it occurs on two different machines connected to the project via source control.

I can manipulate objects by going into wireframe mode, but having to switch between Lit and Wireframe constantly is making me pull my hair out :)

Update: I rolled my project back to 4.18.3 and the widget appears normally. If I update the project again (via a copy) to 4.19.1 the widgets break again.

Update 2: If I start a blank 4.18.3 project with the same basic settings as mine and convert to 4.19.1 it's fine. No clue what is broken in my project.

Product Version: UE 4.19
Tags:
more ▼

asked Apr 27 '18 at 08:09 PM in Bug Reports

avatar image

JBernhelm
11 4 5

avatar image Jeff A ♦♦ STAFF Apr 30 '18 at 01:19 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found the culprit

removing this line in DefaultEngine.ini fixed it

r.compileshadersfordevelopment=0

I believe this setting was previously a part of the "Virtual Reality Best Practices" example .ini

https://docs.unrealengine.com/en-us/Platforms/VR/ContentSetup

more ▼

answered Apr 30 '18 at 07:30 PM

avatar image

JBernhelm
11 4 5

avatar image daveinhampton Jun 11 '19 at 08:32 PM

Lifesaver. Have googled this many times and would arbitrarily blow out half my defaultengine.ini until it was manageable. Finally this is the exact solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question