x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Moving C++ project between computers

I have to work on a project using different computers (home/office). I keep only Config, Content, Source, and ProjectName.uproject -- I regenerate the VS project files each time via right click on project -> "Generate Visual Studio project files".

The problem is, when building the solution in VS (Development Editor / Win64), I get this error:

 UnrealBuildTool : error : Couldn't find target rules file for target 'UE4Editor' in rules assembly 'ProjectNameModuleRules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
  Location: C:\ProjectName\Intermediate\Build\BuildRules\ProjectNameModuleRules.dll
  Target rules found:
      ProjectName - C:\ProjectName\Source\ProjectName.Target.cs
      ProjectNameEditor - C:\ProjectName\Source\ProjectNameEditor.Target.cs
 C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3075: The command "D:\dev\UE_4.19\Engine\Build\BatchFiles\Build.bat ProjectNameEditor Win64 Development "C:\ProjectName\ProjectName.uproject" -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command.

Same problem if building for Development / Win64 (except then it can't find rules file for target 'UE4Game').

I tried keeping all the files (Intermediate, Saved) and it fails with the same error. Both computers use the same version of Unreal. One difference is that on my home computer, UE is installed in a different directory -- but regenerating VS solution takes care of that, I think.

Product Version: UE 4.19
Tags:
more ▼

asked Apr 28 '18 at 07:48 PM in C++ Programming

avatar image

valtron
6 3 8

avatar image Shadowriver Apr 28 '18 at 10:34 PM

UBT never takes VS project in to consideration, at most VS project would not able to run UBT to build as it would have wrong pathing. Did you tried to build cleans project? you sure you copied all the files in Source? try hit rebuild.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Turns out, the project was created with "Enterprise": true (in the .uproject). The UE on my computer is not enterprise.

UBT looks for the UE target rules files (UE4Editor.Target.cs, UE4Game.Target.cs) in different places depending on whether it's an enteprise project or not.

Removing "Enterprise": true fixed the problem for me.

more ▼

answered Apr 28 '18 at 11:43 PM

avatar image

valtron
6 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question