x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Bug: Particle's Vel/Life causes position shift

Hello all, reporting a problem with particle system here.

When you put absolute velocity in Particle's Velocity/Life module, your particle's initial position will be shifted by the same amount without calculating its rotation.

For example, if you put 3000 velocity in x, your particle will always be shifted 3m in world's x coordinate.

I don't get how this is overlooked and no one seems to be reporting any problems with it... But it's currently making particle system unworkable for us. Hope this get fix real soon..

Best,

Product Version: Not Selected
Tags:
more ▼

asked Aug 04 '14 at 05:55 AM in Rendering

avatar image

KillerPenguin
186 12 17 38

avatar image Lovecraft_K ♦♦ STAFF Aug 04 '14 at 02:18 PM

Hi KillerPenguin -

Thank you for your report. I will begin investigation into this issue as soon as possible. If I am unable to reproduce the problem, or I need more information, I or another staff member will follow up with some additional questions for you. Otherwise, I will post an ‘Answer’ once I have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide:

**https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html**

Thank you.

Eric Ketchum

avatar image Lovecraft_K ♦♦ STAFF Aug 04 '14 at 02:27 PM

Hey Killer Penguin -

Can you please upload some screenshots of the issue itself and your Particle System set in particular the Required Module and Velocity/Life Details panel as well as the total module list?

Thank You

Eric Ketchum

avatar image KillerPenguin Aug 05 '14 at 03:31 AM

It's fairly easy to replicate, so I'm just going to send you pointers images below.

alt text

Well, as you can see from the picture, the particle is shifted from its emitter's position. Below is the setting that you need to set in Velocity/Life module. Ticking on the object's using local space does help on the rotation issue, but the particle initial positions is still shifted from it original spawn pos.

This is making our life hell when editing particles. Basically, whenever we change speed, the particle position shifted entirely. Can you help fixed this soon?

alt text

particleshift1.jpg (171.9 kB)
particleshift2.jpg (269.2 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 05 '14 at 01:28 PM

Hey KillerPenguin -

So I copied your system as closely as I could and still could not get it to behave the same way. I did note that shortening the lifetime made the particles appear to "wobble" but only in the sense that it was doing the same X and Z calculations over a shorter timeframe which is expected with a /Life module. I want to check what version of the engine are you using? Is it GitHub compiled or from the launcher?

alt text

Let me know -

Eric Ketchum

vellife.jpg (181.0 kB)
avatar image KillerPenguin Aug 06 '14 at 03:28 AM

This is the latest 4.3 version, straight right from Epic.

I can already see some shift in your image. Notice how the first particle isn't spawning from the object, but from some position ahead of it? Try rotating your emitter without "using local space" option, and the shift will be more visible.

If you still can't replicate this, I'll send you my mock up scene tomorrow.

avatar image Lovecraft_K ♦♦ STAFF Aug 06 '14 at 01:50 PM

Hey KillerPenguin -

I can see what you are talking about, but unfortunately this is the vel/life module working as intended. Essentially because you are setting that velocity at a zero time the particle is being born with a high velocity which causes the offset rendering. There are two ways to fix this and it depends on preference as to which one you would like to use, but both are going to do the same thing.

One is to add a zero time in your vel/life module and change the zero time to 0.1, in this way the particle will be rendered at the origin point and then be assigned its velocity. You can tool with going close to zero in the timeline, but it will slowly get close and closer to offsetting the particle again.

Or, you can add an initial location module to your system and use it to offset the distance back to the system's origin. For my 2000 x 500 z system I had to offset the initial location by -50 on X and 0 on Z to get the system back to the origin location.

Hopefully this can sort out your problem for you -

Eric Ketchum

avatar image KillerPenguin Aug 07 '14 at 01:12 AM

Dear Eric, We already tried adusting that 0 and 0.1 time thing, but that didn't help the amount of the shift is not the initial 0 value, but rather a total sum of the velocity over time.

We have also been shifting emitter position, but that is cumbersome because every time we adjust the speed, the emitter shift to a new place again.

I'm sure it's not really want you and anyone would intend for... It makes it very hard to really do complex particles.

Best,

ps. Have you tried rotating the particle without using the local space or try putting in y velocity?

avatar image KillerPenguin Aug 07 '14 at 01:27 AM

Ok, I've export one of the particles from our game for you here. Hope you can import it. Please try take a look it how the particle position are severely shift from its spawn position...

link text

nattack1_slash.txt (19.5 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 07 '14 at 05:52 PM

Hey Killer Penguin -

I will be happy to look at it, but I will need the *.uasset file of the particle system.

Thank You

Eric Ketchum

avatar image KillerPenguin Aug 08 '14 at 02:23 AM

On a closer investigation, seems like the bug is in Ribbon data type. As you can see, the trail isn't following it source module, nor responding to the object's rotation. (I usually don't render the source emitter, so I didn't see it. And I thought the shift came from the original emitter.)

alt text

Anyway, hope you can replicate/fix it this time, otherwise please tell me how to send you my project.

best,

ribbonshift.jpg (97.6 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 08 '14 at 01:19 PM

Hey KillerPenguin -

I responded to you via your Forum Message System.

Thank You

Eric Ketchum

avatar image Lovecraft_K ♦♦ STAFF Aug 11 '14 at 06:40 PM

Hey KillerPenguin -

Did you make sure that the Inherit Rotation is toggled to true in the Source module of the Ribbon Emitter?

Eric Ketchum

avatar image KillerPenguin Aug 14 '14 at 06:17 AM

"Inherit Rotation" does nothing, the ribbon's position is still shifted. Hope you can test it on what I gave you.

Otherwise, just construct a simple ribbon with source particle and you can test this bug by yourselves. I'm willing to help as much as I can but please fix this really soon though. We could not add any effect to our game at all.

Best,

avatar image KillerPenguin Aug 14 '14 at 06:56 AM

Ok, just to make my point clearer. Here's the two scenarios that we are facing with ribbon data. Please see the pics below.

When we use local space, the ribbon isn't following the source particle. However, the position of the source particle is correct (isn't shifted.)

alt text

When we uncheck the local space, the ribbon data follow the source particle correctly. However, there's a bug that cause the source particle's position to shifted from the emitter. (Can you see how the particle isn't spawning at the green arrow now?) SO the whole thing shifted by some amount.

alt text

Please notice that both pic have the same parameters, the only different in the second pic is that the "local space" potion isn't checked.

This shift become very severe when we have small life and high velocity. With this bug, both scenarios cannot be worked with... and we're left with broken particles system that can't correctly handle high velocity particles.

It does't matter which scenarios you fix, I just want one working option with this...

shifted1.jpg (45.1 kB)
shifted2.jpg (41.8 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 14 '14 at 03:38 PM

Hey KillerPenguin -

Ok, I've been working with your assets and creating duplicates in various engine versions. I 've been able to reproduce the behavior in Scenario One above when both modules have a checked local space I am getting the offset as you show above. However I am not able to reproduce the Scenario 2 yet. The Ribbon Emitter follows the particles just fine without local space checked. I am going to go back through your assets again to double check every setting.

Thank you for the information above it helped me narrow down the scope a lot.

Eric Ketchum

avatar image KillerPenguin Aug 15 '14 at 01:42 AM

Hmm, I think you are a bit confused. To break it down even further, there's 2 bugs:

  1. Ribbon Data doesn't follow its source particle when local space option is checked.

2, When local space option is unchecked, there's a slight "position shift" in weird direction from emitter with high velocity. This actually has nothing to do with ribbon data. I believe the bug is in emitter's initialization with high velocity.

Anyhow, at least, could you fix scenario one for now then? I see no use in having Ribbon Data that doesn't follow its source particle anyhow. I would like to get scenario two fix later too, I'm sure many people will encounter this bug again and again.

avatar image Lovecraft_K ♦♦ STAFF Aug 15 '14 at 02:33 PM

Hey KillerPenguin -

I have entered this information with our Developers and will keep you informed as we work on these issues.

Thank You

Eric Ketchum

avatar image KillerPenguin Sep 23 '14 at 06:42 AM

When will this be fixed? I'm pretty frustrated with this actually....

avatar image Lovecraft_K ♦♦ STAFF Sep 23 '14 at 01:48 PM

Hey Killer Penguin -

Normally I have to deliver bad news, but today GOOD NEWS!! This issue has been fixed on our internal branch of the engine and should be included in the next engine release.

Let me know if the problem persists or returns after that release -

Thank You

Eric Ketchum

avatar image KillerPenguin Sep 29 '14 at 03:17 AM

Holy macaroni! Ty Epic, I can't wait for it.

avatar image KillerPenguin Oct 15 '14 at 04:16 AM

I'm very disappointed, this is still not fixed in unreal 4.5.

avatar image ThisGuy5234 Oct 15 '14 at 06:11 PM

Hi,

any news concerning a bugfix after 4.5 ? If you need repro-data, please let me know.

Thanks, Carsten

avatar image ThisGuy5234 Oct 15 '14 at 07:24 PM

Nevermind. My issue seems to be fixed in 4.5. In 4.4.3 local space did not work.

avatar image Lovecraft_K ♦♦ STAFF Oct 15 '14 at 08:01 PM

I have attached a Sample Project with a Default Particle System to this post. I am not seeing any bug related to a shift in position when Vel/Life is set to Absolute as long as the Emitter is set to Local Space. I have also slowed the emitters themselves down in the level using a time dilation so the particle can be seen spawning at origin and then moving.

Thank You

Eric Ketchumlink text

avatar image KillerPenguin Oct 20 '14 at 06:48 AM

Dear Eric, I won't be trolling over this issue if there wasn't a problem with positions in UE emitter.

I understand that it works in most cases, but if you really want to tweak them to the limit, then this bug need to be solved. I have made several bugged examples using "local space" and send them over to your staffs and I'll be willing to do so again. Just give me another email and I'll re-create the bug using 4.5.

Best,

avatar image Lovecraft_K ♦♦ STAFF Oct 22 '14 at 01:40 PM

Hey KillerPenguin -

I absolutely do not think you are trolling at all. If you see an issue we want to try to address it as best we can. That being said I have sent you contact information about a way to get a sample project to use that demonstrates your issue.

Thank You

Eric Ketchum

avatar image KillerPenguin Oct 23 '14 at 03:14 AM

Well, pic below is from 4.5. Same thing as before, particle is shifted in weird direction when local space is not ticked. (And when it's ticked, ribbon data is not rotated with it, making it unusable.)

I already sent this sample project to you in via mail. Hope you could really fix it this time.

alt text

particleshift.jpg (283.7 kB)
particleshift.jpg (283.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey KillerPenguin -

I have re-entered a bug report using your assets for the test case (UE-4523) and will keep you up to date as we continue to investigate this issue.

Thank You Again for your help -

Eric Ketchum

more ▼

answered Oct 23 '14 at 02:28 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image KillerPenguin Nov 10 '14 at 02:00 AM

SO after all my time creating all these project files to show the bugs, The issue get shrugged back into the rug and queue up to be tested again? What happens to this promise? ->

"Normally I have to deliver bad news, but today GOOD NEWS!! This issue has been fixed on our internal branch of the engine and should be included in the next engine release."

I'm very disappointed to say the least...

avatar image Lovecraft_K ♦♦ STAFF Nov 10 '14 at 02:34 PM

Hey Killer Penguin -

There were originally two different issues that your issue ended up being reported and the first issue "Ribbon Data doesn't follow its source particle when local space option is checked." and that issue has been fixed. The second issue (the one that obviously is more concerning to you) was not placed back under the rug but was and is in fact still being worked on. I reported it again so that it would not be lost in the shuffle.

I appreciate your concern and we are working toward a solution as fast as we can.

Thank You

Eric Ketchum

avatar image KillerPenguin Dec 10 '14 at 01:02 AM

Well, the problem is still there in 4.6.

avatar image bzxo Sep 07 '15 at 11:43 AM

Same bug in 4.9

avatar image Lovecraft_K ♦♦ STAFF Sep 08 '15 at 08:53 PM

From our Graphics Programmer:

"The offset from center is related to the spawn/tick order of operations. With these high velocities, small variations in frame rate during spawning make a huge difference. The emitter is also offset by 100 on each axis in the spawn module, so it's not going to spawn directly on the origin, but the biggest issue is that, with framerate variations, the initial spawn location can vary substantially because we update particles immediately after spawning - so the first time the ribbon emitter runs, it'll spawn from the initial location that has already been updated by the velocity, which is large, which is going to offset the initial particle substantially from the origin.

A possible workaround: insert one additional control point at the beginning of the curve, at an InVal of 0.0 with a small X velocity of 0.1 or so to trigger the SpawnPerUnit module, and constant interpolation. Move the second control point to InVal around 0.3 (0.2s * 0.3 = 0.06s or 60ms) instead of 0.0. This should make sure that the initial movement of the particles directly after spawn is very small, so they're likely to be very close to the center except in the unlikely case of a long hitch. The above fixes the issue with this particular emittter for me."

This issue is still listed as backlogged. I have bumped the community interest again.

Thank You

Eric Ketchum

avatar image KillerPenguin Sep 11 '15 at 12:54 AM

That's not it. if local space has one problem, and world space has another, I would say the problem lies somewhere else.

Your programmer just doesn't take it seriously. The ability for users to directly influence how particles precisely move in a line is actually very neat and crucial if you want to create something spectacular.

It's over a year now and I really doubt that this will ever get fixed.

avatar image Burnrate Dec 16 '15 at 08:18 PM

Hi Eric,

I just wanted to voice my support for this issue to be worked on.

I wasn't able to successfully implement the workaround but that is probably because of my misunderstanding.

Thank you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question