x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't upgrade 4.18.3 project to 4.19.2

Hey Everyone, I'm having some issues upgrading my C++ project from UE4.18.3 to 4.19.2

I already tried rebuilding the solution and regenerating visual studio files. I also tried all of the steps here to no avail: https://answers.unrealengine.com/questions/771273/having-issues-converting-code-projects-from-4183-t.html

This is the error I'm getting when I try to upgrade from the unreal engine launcher: Project files could not be generated. Log output:

 Running G:/Program Files/Epic Games/UE_4.19/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="G:/Documents/PunchBombBackup/2018-04-07/PunchBomb 4.19/PunchBomb.uproject" -game -rocket -progress
 Discovering modules, targets and source code for project...
 While compiling G:\Documents\PunchBombBackup\2018-04-07\PunchBomb 4.19\Intermediate\Build\BuildRules\PunchBombModuleRules.dll:
 ERROR: g:\Documents\PunchBombBackup\2018-04-07\PunchBomb 4.19\Source\PunchBomb.Target.cs(8,9) : error CS1729: 'UnrealBuildTool.TargetRules' does not contain a constructor that takes 0 arguments
 ERROR: g:\Documents\PunchBombBackup\2018-04-07\PunchBomb 4.19\Source\PunchBombEditor.Target.cs(8,9) : error CS1729: 'UnrealBuildTool.TargetRules' does not contain a constructor that takes 0 arguments
 ERROR: UnrealBuildTool Exception: Unable to compile source files.

And this is the error I'm getting when trying to convert by right clicking the unreal project file:

 Running G:/Program Files/Epic Games/UE_4.19/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="G:/Documents/PunchBombBackup/2018-05-03/PunchBomb 4.18/PunchBomb.uproject" -game -rocket -progress
 Discovering modules, targets and source code for project...
 ERROR: UnrealBuildTool Exception: Unable to instantiate instance of 'PunchBombTarget' object type from compiled assembly 'PunchBombModuleRules'.  Unreal Build Tool creates an instance of your module's 'Rules' object in order to find out about your module's requirements.  The CLR exception details may provide more information:  System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.MissingMethodException: Method not found: 'Void UnrealBuildTool.TargetRules..ctor()'.
           at PunchBombTarget..ctor(TargetInfo Target)
           --- End of inner exception stack trace ---
           at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
           at System.Reflection.RuntimeConstructorInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
           at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
           at UnrealBuildTool.RulesAssembly.CreateTargetRulesInstance(String TypeName, TargetInfo TargetInfo)


Anyone run into anything similar or have an idea on how to fix it? I need to upgrade to get the project working properly on Windows Mixed Reality (doesn't play nicely with SteamVR in 4.18.3 apparently)

Product Version: UE 4.19
Tags:
more ▼

asked May 04 '18 at 03:08 AM in Using UE4

avatar image

Oraclefish
99 11 14 21

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question