x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

NavMesh fail to rebuild at runtime dynamic obstacles

Hi !

i came to hit a strange bug with dynamic obstacles, when an obstacle moved, the nav mesh has to rebuild the area, so it discard it, but never rebuild it...

at runtime : pic0 pic1

By luck, i found that if i make the area to be rebuild in editor and try again, it does work (only for this area, other still buggy) , and after rebuilding the full mesh, everything works again.

The nav mesh rebuild is buggy on one of my coworker computer, so we disabled the auto one, and only i rebuild it from time to time, so the mesh was few weeks old ( but it was already a 4.17.2 one ). so the lvl had changed a bit, but not that specific part of the lvl

So i'm not asking for a fix as the workaournd is good enough and 90%+ of people probably have auto nav mesh generation. But just posting this so you guys know it exist, and if somebody has the same problem he doesn't loose half a day thinking he broke something :p

have a good day ! :) Additional infos:

-c++ project, 4.17.2, from luncher binaries

-my "runtime Generation" Setting is "Dynamic modifiers only"

-it does work on an other smaller test map in the same game with similar settings

-it does work if i set Runtime Generation to "Dynamic" but i don't want a full rebuild of areas

Product Version: UE 4.17
Tags:
capture1.jpg (80.3 kB)
capture.jpg (62.4 kB)
more ▼

asked May 04 '18 at 05:31 AM in Bug Reports

avatar image

Firefly74
1.3k 13 17 31

avatar image Jeff A ♦♦ STAFF May 04 '18 at 03:49 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question