x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal editor stuck at 45% and won't go futher

Hello! I've git cloned unreal engine 4 sources and checked out to tag 4.19.2

After success build and run it (Unreal Editor, not a project!), it does some job (compiling shaders) and stucks, cpu load is 15-20% when it stucks.

I tried deleting everything, rebuilding.

I'm using visual studio 2017.

PC specs: intel core i7 7700k 32 gb ram ue4 sources are on raid0 SSD array

Please help me resolve it!

Product Version: UE Github Master branch
Tags:
more ▼

asked May 06 '18 at 08:07 AM in Using UE4

avatar image

Wadimich
16 1 4 7

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

If you compile the Unreal Engine by yourself, the first time you open it (just the first time), it will take a long time before run because it compiles shaders and does other stuff. Just be patient and you'll see that eventually it will run.

more ▼

answered May 07 '18 at 10:47 AM

avatar image

andrea.b
1 1 3

avatar image Wadimich May 07 '18 at 10:51 AM

I waited more than hour, on very good CPU... And as i said, CPU load at 100% will be only for 10-20 seconds, after only base process do some "work", which is endless

avatar image andrea.b May 07 '18 at 10:57 AM

I checked out 4.19 version from Github. I compiled the whole Engine and the first time I launched the editor it remained stuck for a while (I don't remember how much it was but it was not a short time).

Try this, when you launch the Unreal editor, open the Task Manager and see in the Unreal Engine sub processes if Unreal Shader Compilers are there. If they are, then definitely the Engine is compiling the shaders that it needs to start the first time. In that case, I say it again, just be patient.

avatar image Wadimich May 07 '18 at 10:58 AM

They are for 10-20 seconds, after that only single Unreal Editor process is eating up to 20%.

(comments are locked)
10|2000 characters needed characters left

They were complaining of this (with no solution) since at least 4.12 !!! I installed 4.21.1 I ran it and created a new project, then as it is opening the new project,.. Stuck at 45% since yesterday about noon.. about 21 hours (so far...) 8th Gen core i7, 16GB ram,. TX 1080 Ti Founder edition, etc. (and all Mega fast M.2 SSD WD Black drives!

I think someone found the answer about ten years ago, "SWITCH TO UNITY",

Now that would be, SWITCH To LUMBERJACK!!

That seems to be the only answer I can find,.. :~)

What a joke, working in Unreal, is like living in a NIGHTMARE but I can't wake up! (or start a new project LOL LOL

LOL LOL LOL TEARING MY #^#%&() HAIR OUT!

HATE UNREAL

HATE EPIC LOLOL LOL HHAHAH

JOKE OF THE COSMOS that they are named: 'Epic' ... Epic fail...

more ▼

answered Dec 07 '18 at 12:06 AM

avatar image

NextWorldVR
0 3 5

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question