x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird dark spots in corners only in between sloped surfaces.

If anyone have some suggestion how to solve following problem, please help. I cannot get rid off dark spots like this (They only appear where the upper surface is sloping.):

dark spots dark spots

UV layout seem to be ok - enough spacing, but I see some analogy between uv layout elements and dark spots like below:

uv layout lightmap

Increasing Indirect lighting quality does not solve the problem. Actually I get more of them than when it was set to 4 or 6.

lightmass setting

Product Version: UE 4.19
Tags:
more ▼

asked May 07 '18 at 12:47 PM in Rendering

avatar image

krecik000
6 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

You don't have enough lighmap resolution to get proper results. You should have less meshes attached together because like this it's "impossible" to achieve realistic results! You just can't set high enough (the max is 4096) lightmap resolution (not to mention calculation time)! So let's say you have this max setting. Then as you can see on the attachment your wall gets 1024 res all together! ...which might be enough (I guess you had a lower res... if it was 2048 then your wall has only 512... ...)! alt text But you would have a faster build calculation with separate walls and lower lightmaps not to mention to control completely your lightmap resolution per mesh! The other thing is: snapping corners to grid/pixel + straightening edges! You'll have a lot less (or not at all!) artifacts if you won't have diagonal edges but everything is 90 degrees! You can stretch your lightmap uv island to a certain amount (I've even seen extreme cases!).

lightmap-uv.jpg (497.3 kB)
more ▼

answered May 07 '18 at 02:57 PM

avatar image

Makigirl
1.2k 3 4 8

avatar image Makigirl May 07 '18 at 03:05 PM

...I might be wrong but if I see it right your walls are just planes!! Your walls should have thickness to avoid those kind of "bleeds"! For correct calculation/samples unreal needs to have inside samples/information to calculate the bounces properly! ...and if you don't have thickness you can't lower the Volumetric Lightmap Detail Cell Size enough to get inside...

avatar image krecik000 May 07 '18 at 03:44 PM

I set 2048 lightmap resolution for this object which gives me pretty high resolution for all included walls. You can see it with Lightmap Density mode (marked red everywhere). Each dark spot cover lot of lightmap pixels:

lightmap density

All objects / walls / door frames / floors etc create closed volume without any gap that light can leak through. It is working perfectly everywhere else except those sloping surfaces:

alt text

avatar image Makigirl May 07 '18 at 03:57 PM

I'm sorry, I guess we are after different quality!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question