Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Visual Studio editor saying 'Macro in Skipped Region'

Visual Studio is saying macro in skipped region after a recent update. It didn't show this message before the update.

alt text

The code compiles fine but how to remove this error message?

Product Version: UE 4.19
screenshot-12.png (32.5 kB)
more ▼

asked May 08 '18 at 06:57 AM in C++ Programming

avatar image

46 4 2 4

avatar image Congruent_ May 15 '18 at 05:42 AM


(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

A Workaround

Bit of a hacky workaround, but try this for now:

  1. Add a cpp.hint to your root folder

  2. Add the missing defines in here, for example, mine is:

    #define UCLASS()

    #define GENERATED_BODY()

    #define UFUNCTION()

  3. Restart visual studio and give it a few seconds. This should get rid of your green squiggles.

  4. List item


Microsoft's Hint File Docs


more ▼

answered May 15 '18 at 06:43 AM

avatar image

21 2 4

avatar image BugSwat May 24 '18 at 01:17 PM

This is a nice workaround. Thank you for sharing.

But: I'd just leave the whole thing alone. I mean, it is not an error, it is an information from the IDE. Keep it in your sights but do NOT change your code because of IntelliSense information.

avatar image Congruent_ May 24 '18 at 06:40 PM

It's incorrect information from the IDE (as acknowledged by Microsoft). I even added my cpp.hint file to the visual studio installation directory; so it doesn't even have to live in your project root. It's simply an editor configuration... and it's not modifying any code whatsoever.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having the same issue. The weird part is that it is hard to find official references to this "Macro in Skipped Region". There are a lot of people complaining about this, links for reference:

The best solution comes from the later where it suggests disabling this warning by disabling IntelliSense as a whole. Unfortunately, I couldn't find a way to disable only this warning but I can live with it until a fix comes out.

In order to fully disable IntelliSense:

  • Tools -> Options -> Text Editor -> C/C++ -> Advanced -> Disable IntelliSense

more ▼

answered May 12 '18 at 10:27 PM

avatar image

248 5 11 13

avatar image Roi Danton May 15 '18 at 06:16 AM

I recommend to vote on visualcommunity so the VS Devs priorities that. Using hint files or deactivating Intellisense don't seem viable solutions to me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question