x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Oculus Go - ExposureCompensation (post process) not working?

According to this page, you should be able to control to the exposure on GearVR (GO).https://docs.unrealengine.com/en-us/Platforms/GearVR/BestPractices

For a project with an interior and exterior on the GO I really would like to control the Exposure Compensation. I added two volumes but the exposure settings don't seem to have any effect. Any suggestions?

Easily tested by creating a simple scene with two PostProcessVolumes; One PPV unbound - priority 0 + ExposureCompensation 0. And another PPV with priority 2 and ExposureCompensation 2

Product Version: UE 4.19
Tags:
more ▼

asked May 16 '18 at 08:17 PM in Rendering

avatar image

maxbrown
161 5 7 14

avatar image Norman3D Nov 11 '18 at 09:06 PM

It should work. However it has been broken since Unreal 4.19 after it changed name from Exposure Bias to Exposure Compensation :/

avatar image maxbrown Nov 12 '18 at 06:20 AM

Actually, to get this to work mobile HDR must be enabled. If you can't afford the fps drop that comes with mobile HDR - maybe just add some extra lights inside and delete the PPV volumes altogether.

avatar image Norman3D Nov 12 '18 at 07:24 PM

It's a bug. Exposure Compensation should work even with Mobile HDR turned off. That's what the documentation here states: https://docs.unrealengine.com/en-us/Platforms/GearVR/BestPractices And here: https://static.docs.arm.com/100959/0100/arm_guide_for_unreal_engine_4_optimizing_mobile_gaming_graphics_100959_0100_00_en.pdf

And last but not least, it's even in the MobileBasePassPixelShader.usf

     #if !MATERIALBLENDING_MODULATE && OUTPUT_GAMMA_SPACE
         // MobileHDR applies PreExposure in tonemapper
         OutColor.rgb *= ResolvedView.PreExposure;
     #endif

PreExposure is applied in the tonemapper IF and only IF MobileHDR is turned on. IF it's NOT then it's multiplied in the PixelShader, which is the bit of code I've posted above. The specific bug is that the Exposure Compensation is not properly going through PreExposure and seems to be constantly at 1.0.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
more ▼

answered Nov 12 '18 at 07:43 PM

avatar image

Norman3D
96 2 4 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question