x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Shader Compiling Really Slow

I'm using UE 4.19 and everytime I make a change on a material (It can be a simple color or texture change) the shaders start compiling in a slow way. I tried doing the same action in 4.18.3 and the changes on materials are almost instantaneous.

Does anyone know if the new version is having some problems?

Thx for the help.

Product Version: UE 4.19
Tags:
more ▼

asked May 17 '18 at 07:47 PM in Using UE4

avatar image

Tabacudo
62 3 4 13

avatar image Samael91 Jun 22 '18 at 03:50 AM

Hi Tabacudo, This is indeed true. My UE 4.19 took over one hour to compile shaders, for an Android Launch My PC was under full stress for the entire duration. I request the development team to look into this issue as well.

avatar image Sjonsson Aug 15 '18 at 01:07 PM

Heya!

I have this issue in 4.20 and it seems that the PriorityModifier is still on -1.

You can change it manually in the Task Manager for sure but whenever you restart the editor it's going to reset.

I'm not sure this is all there is to the problem though. Even though I set it to High priority it takes waaaay longer than before.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

This appears to be resolved for many users (including myself), by changing the shader-compiler's windows task priority: This page has a fellow with some degree of solution.

https://answers.unrealengine.com/questions/735848/shadercompileworkerexes-task-priority-is-too-low.html

[Update] Adrian provided me to a small utility he wrote to compensate for this issue without recompiling the engine: https://github.com/AdrianJMartin/FixUnrealShaderPriority

more ▼

answered Jun 22 '18 at 11:24 AM

avatar image

DarthPJB
236 2 5 6

avatar image DotCam Jun 22 '18 at 04:46 PM

Thank you for posting that link, setting the priority higher does make a difference. Just a bit annoying you need to keep setting it every time you use the engine.

Might look into creating a pull request where the priority could be changed in an ini file rather than needing to build from source just to change that one line.

avatar image DarthPJB Jun 22 '18 at 11:34 PM

If you do, I think a fair number of people would endorse in - it's odd to have a hard-coded value for something so vital.

avatar image DarthPJB Jun 26 '18 at 11:37 AM

@dotcam I've updated my post with a small utility.

avatar image DotCam Jun 27 '18 at 01:20 AM

Awesome! Not sure I would have been able to look at this for a while, just slammed currently, so that's great someone was able to create this

Thank Adrian for me!! and thanks for letting me know! I'll start posting this fix into all the other shader compiler is slow threads I come across. :)

avatar image WINDYNIKO Jun 27 '18 at 03:51 AM

@DotCam I clicked on exe but it didn't work and the compiler was still slow

avatar image DarthPJB Jul 31 '18 at 06:21 PM

what exactly didn't work?

avatar image SergeVed Jul 31 '18 at 02:27 PM

i can't even find an exe file...

avatar image Tabacudo Aug 20 '18 at 07:17 PM

Hey Guys! There is no .exe file. You need to compile the code. I'm having trouble at compiling though. :/

avatar image Tabacudo Aug 21 '18 at 12:46 PM

I was able to compile. But still, it didn't help me.

I tried using the code, but no change was made. The .exe runs but it seems the engine always try to keep the original priority, and the fix has to keep trying to change it. I haven't noticed big changes even with the fix cause Unreal keeps changing the priority and shaders keep going slow.

The fix's logs became insane, lol.

I downloaded the version 4.18 again, since I'm just working with render by now. Hope it gets fixed soon.

Thx everyone for helping.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This trick will only work if u have a single core CPU or if UE4Editor.exe is eating and up more than 1/(Total cores if ur CPU). For my UE4Editor and 3 ShaderCompiler exe is taking up 25% of all CPU's so no performance gain.

more ▼

answered Apr 14 '19 at 06:04 AM

avatar image

Foxtrot 47
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I want to bump this to try and have UE devs say if we're doing something wrong or if it's something they're going to fix.

more ▼

answered May 16 '19 at 09:28 AM

avatar image

Sjonsson
6 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question