x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

how force UE4 to use just visual studio ?

no matter what I do UE4 run visual studio 2015 on my pc. Edit->Project Settings-> Platforms-> Windows -> Toolchain ->CompilerVersion. i did this but its not work .

how can I force it to use 2017 only?

Product Version: UE 4.18
Tags:
more ▼

asked May 23 '18 at 03:22 PM in C++ Programming

avatar image

AAriyAA
59 4 7 14

avatar image MrMcKvarz May 23 '18 at 05:11 PM

Hi, as far as I know, unreal tries to use the oldest visual studio installed, and the only way is to have only one studio. That, however, can be untrue, but it's how I usually deal with it.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

UnrealBuildTool have a -2017 and -2015 options to force version, try generating project files with that option

https://docs.unrealengine.com/en-us/Programming/UnrealBuildSystem/ProjectFileGenerator

Appertely it makes UBT compile in that version too, but if not look up in project settings in VS, in NMake section there sould be custom UBT build commands an add -2017 option

Note that UBT use VS only for compiler and VS IDE it self is just use only as text editor, any compilation configuration there is ignored and UBT only follows build scripts (*.cs files in source directory)

more ▼

answered May 23 '18 at 07:05 PM

avatar image

Shadowriver
33.9k 916 164 1093

avatar image AAriyAA Jun 02 '18 at 10:43 AM

Hi Shadowriver . thanks for your fast reply and please accept my apology for my late reply. I cant find the file I must add -2017 command in it, can you give us more detailed description cause I'm really new in C++ especially in unreal. i found UBT file in this address : :\Program Files\Epic Games\UE_4.18\Engine\Source\Programs\UnrealBuildTool\DotNetCore if its that file just add -2017 is it enough? thanks.

avatar image AAriyAA Jun 02 '18 at 12:24 PM

i find out i must edit this file :\Program Files\Epic Games\UE_4.18\Engine\Saved\UnrealBuildTool\BuildConfiguration.XLM

I add -2017 with text editor in it and I did generate visual studio file again and it doesn't work still, UE4 continue run 2015 version.

 <?xml version="1.0" encoding="utf-8" ?>
 <Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">
 </Configuration>
 -2017
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question