x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle Parameter colour change not working in viewport or via blueprints.

Hi,

I am trying to get a simple colour change going for some smoke. I have read the guide on particle parameters, read a lot of other threads and watched some videos. I have followed them step by step but I still cannot get my colour to change through the instance parameters in my particle component. My material has a particle colour.

The colour does change when I change the 'constant' part of the Color Scale Over Life, but that is not much use to me since I cannot access that from the viewport/blueprints.

As you can see from the below images, all the settings should be alright but the colour is still just white...

Any help appreciated.

alt text

alt text

alt text

Product Version: UE 4.19
Tags:
1.png (342.4 kB)
2.png (120.5 kB)
3.png (433.6 kB)
more ▼

asked May 23 '18 at 04:32 PM in Rendering

avatar image

JustOnCardThanks
1 1

avatar image Jeremy Q ♦♦ STAFF May 25 '18 at 08:44 PM

Hello,

After testing this on my end I did not run into the same issue. What exactly are you trying to achieve with the particle parameters?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

I know it's really late, but still better than never ^^

I understand thanks to this post

GPU Sprites emitter can't accept Dynamic parameter. And when you expose parameters in your blueprint, it is considered as Dynamic.

But when you put your blueprint in the scene, if you go in Details window, select your particle system, and expose parameters, they are considered as "Static". (I try a parameter for Spawn and it works)

Nevertheless, Color is always considered as Dynamic parameter. (It is not working even in Details window)

Likewise, the blueprint functions setFloatParameter, setVectorParameter, ..., setInstanceParameters, will work on Construct and on Play for all "Static" parameters but not for Color.

Set Material alt text Set Spawn parameter alt text Set Color parameter alt text Not Working in Blueprint Editor alt text Working in Details Window for Spawn but not for Color alt text

more ▼

answered Jan 12 '19 at 12:20 PM

avatar image

bstt
111 1 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

more ▼

answered Jun 01 '18 at 06:05 PM

avatar image

Jeremy Q ♦♦ STAFF
946 3 7 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question